Wetty Docker possible on Rpi 3?

I discover Wetty docker but it failed on my Raspberry Pi 3! Information on : https://hub.docker.com/r/svenihoney/wetty

docker pull svenihoney/wetty
docker run -dt -e REMOTE_SSH_SERVER= -e REMOTE_SSH_PORT=22 -e REMOTE_SSH_USER=root -p 3000 --name term svenihoney/wetty

In portainer, it says it’s running but it doesn’t work on Rpi 3 (only on Vmware Virtual Machine)! I guess that I need an Armv7 for Rpi but I can’t find any. I search for others dockers, but none offers the same functionnality! Does anyone knows a Rpi docker that does that (I prefer docker) or as 2nd choice and easy way to do it without docker.


according docker.hub it’s an amd64 docker image and therefore not able to run on armhf

Ok, thanks for the info!

Probably my answer was to fast :slight_smile:

Basically for a privat project I end up same situation. But I was able to discover a cool easy way to overcome this. Trick is to build your own image on your RPi. This is possible using Portainer. It has a build in function to create images from GitHub source. Luckily Wetty is offering one for the docker image. :wink:

I got wetty up and running on my RPi4B aarch64. Ok it’s 64bit bit, but should be working same way on 32bit

Wow! It seems very nice!!! I use portainer for quite a while but I’m not to sure how to do that? Can you give me more details?

Yup…seems there are arm version out there


This might work

docker pull jlerma27/wetty
docker run -dt -e REMOTE_SSH_SERVER= -e REMOTE_SSH_PORT=22 -e REMOTE_SSH_USER=root -p 3000 --name term jlerma27/wetty

question is if stephane77 like to use svenihoney/wetty or if he is ok to use jlerma27/wetty.

If it need to be venihoney/wetty, a rebuild is needed to have it running on arm :wink:

Hi everyone,
Happy new year!

I would prefer to use venihoney/wetty for multiple reasons. There is over 5M+ downloads for that docker; it must be a very good one, well tested, up to date and I would like to learn. Also, I might need to do that in the future for other dockers!

I’m curious. Can anyone provide me the steps how to do it?


ok this guide I created on a RPi 3 Model B+ (armv7l) running DietPi v6.34.3

  1. basic DietPi installation
  2. install Git (ID 17), Docker (ID 162), Portainer (ID 185) using dietpi-software
  3. open Portainer
  4. connect to your endpoint
  5. go to images
  6. click + Build a new image
  7. name: dietpi/wetty
  8. select Build method: URL
  9. URL to be added: https://github.com/svenihoney/docker-wetty-alpine.git
  10. hit: Build the image
  11. this will take time now … For me it was around 30 minutes
  12. to watch the progress, connect to your system using SSH and open htop. There should be some activity as long as the new image will be created
  13. once completed, portainer will switch and show the output. Don’t worry if it’s empty showing No build output available.
  14. now you are able to start container from command line (SSH)
docker run -dt -e REMOTE_SSH_SERVER=192.168.x.x -e REMOTE_SSH_PORT=22 -e REMOTE_SSH_USER=root -p 3000:3000 --name wetty dietpi/wetty
  1. It will expose port 3000. Ensure it’s not already used by other application
  2. on portainer > images you can remove the unused image without tag. This was used to build ours. On the other hand node:carbon-alpine you are not able to delete as it is a parent image for our wetty one
  3. now Wetty should be reachable on http://192.168.x.x:3000

And Happy New Year 2021

Thank you Joulinar! It works like a charm! One quick question!

At home I access Rpi with http://RaspberryPi:3000 or

If I use REMOTE_SSH_SERVER=RaspberryPi it fails but it works only with the ip address… any reason why?
docker run -dt -e REMOTE_SSH_SERVER=RaspberryPi -e REMOTE_SSH_PORT=22 -e REMOTE_SSH_USER=root -p 3000:3000 --name wetty --restart unless-stopped dietpi/wetty


it’s basically similar to what we discussed on the AriaNG topic. You would need to check DNS resolution from inside the container


Very awesome!!!

Hi Joulinar,
Maybe I didn’t explain well or I just don’t understand! I tried both scenarios.

docker run -dt -e REMOTE_SSH_SERVER=RaspberryPi -e REMOTE_SSH_PORT=22 -e REMOTE_SSH_USER=root -p 3000:3000 --name wetty --restart unless-stopped dietpi/wetty
docker run -dt -e REMOTE_SSH_SERVER= -e REMOTE_SSH_PORT=22 -e REMOTE_SSH_USER=root -p 3000:3000 --name wetty --restart unless-stopped dietpi/wetty

This one “REMOTE_SSH_SERVER=” works.

The difference with AriaNg I can ping everything. I can ping google.ca, google IP and RaspberryPi within WeTTy so the docker is alright! Maybe the “REMOTE_SSH_SERVER” expects an IP and not a domain? RaspberryPi = and as a safety measure it’s blocked, just guessing!

I just thinking that I can’t build the docker with the domain because it’s expecting an IP and nothing else? Just try to understand if it’s a limitation, a safety measure or what!


Hi stephane77,

I fully understood you. I did a test and was able to use a DNS instead of IP address. Means, it’s working this way as well.


You would need to check DNS settings inside the container to ensure the container knows who RaspberryPi is. It can be checked as follow

docker exec -it wetty cat /etc/resolv.conf

Hi Joulinar,

I am trying to build this image from your guide for the offical github repository, but I get an error.

I would rather use this than svenihonney which is no loinger maintained.

Do you have any idea why this is happening?

Maybe you should have shared the error message. Otherwise it will be hard to help or to know what happened.

If wetty is not working, you could try our own DietPi-Dashboard (software ID 200). It offers a ssh terminal as well.

Sorry about that.
I just get “unable to build image”
unable to build image.PNG
Nothing in the portainer logs i can share.

I have tried with this path.

and this path also.

as far as I can see, they changed repositories.

And on the current on, looks like they have issues to build on ARM https://github.com/butlerx/wetty/pull/379