Weird speedtest behaviour


I’m experiencing a “weird” issue with my rpi. Basically, when I run the speedtest command (from ookla) I always get around 200 Mbps with the default server (closer) whereas if I pick another server a get around 520 Mbps (hired speed is 500 so it’s fine). One can think that the closer server has an issue, but here comes the “weirdness”: whenever I run the test to the same server on my laptop, phone etc. I still get the 500 Mbps (even on wifi). For some reason, my rpi struggles to get past 200 Mbps when connected to that server — what could be the cause?


did you check cpu usage?

Speedtest are not always reliable. There are quite some dependencies to get the best speed. Like how many parallel tcp connections used, the route on the internet, usage of taget server aso. And the nearest one is not always the fastes one.

1 Like

I might have not been clear, but I’ll explain again: I’m running the speedtest on my Pi which is connected to the same switch as my computer and other network devices. Whenever I run the test to the same test server (which is the closer one) with my other devices I can get the hired speed with no issues, however, with the Pi only it caps at around 200 Mbps.

The weird thing, is that with the Pi, connected to another server it gets the hired speed as well (500 Mbps).

TL;DR: The pi seems to not get more than 200 Mbps with a particular server when other devices in the network get it just fine.

I don’t think you will find an answer on your question as this is dedicated to a specific test server and not a general issue.

1 Like

I was trying to figure if different servers provide different configs and the Pi could be picky about that.