webmin update reinstall failed

Hi all

on my NUC, I updated Webmin recently then it crashed, so I uninstalled and tried to reinstall it but it stuck at “Setting up webmin (1.941) …”

then I got something like that “dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem”

I’ve look for solutions but nothing works

any idea ?

also when I run a cleaner selecting APT cache I got :

Log file content:
│ E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily
│ unavailable)
│ E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another
│ process using it?


ps aux | grep -i apt


root 3865 0.1 1.9 91460 78448 ? S 11:44 0:02 apt-get -qq --allow-change-held-packages install webmin
root 5863 0.0 0.0 6096 880 pts/2 S+ 12:13 0:00 grep -i apt

did you tried to reboot your system to clean temp locks?

reboot yes cleaning no how do I do that ?

if you check after the reboot for running apt processes, do you see some?

it seems no

ps aux | grep -i apt

root 1236 0.0 0.0 6096 824 pts/0 S+ 12:47 0:00 grep -i apt

what happen if you run the following as root

dpkg --configure -a

sudo rm /var/lib/apt/lists/lock
rm: impossible de supprimer ‘/var/lib/apt/lists/lock’: Aucun fichier ou dossier de ce type

root@DietPi:~# sudo rm /var/cache/apt/archives/lock
rm: impossible de supprimer ‘/var/cache/apt/archives/lock’: Aucun fichier ou dossier de ce type

root@DietPi:~# sudo rm /var/lib/dpkg/lock

root@DietPi:~# sudo dpkg --configure -a
Paramétrage de webmin (1.941) …

still pending …

dpkg --configure -a
Paramétrage de webmin (1.941) …

pending too …

yes dpkg --configure -a could take a while is it trying to configure the software

ok so I let in run

I’ll keep you informed

it’s still stuck …

did you get any error message?


no error no message just

“Setting up webmin (1.941) …”

So, as I have not found any solution I would like to reverse the installation

does anyone knows what the installation script does ?

or force the uninstall script ?

usually you can run dietpi-software to uninstall stuff that was installed with DietPi tools.

yeah I know but as the installation failed there is no webmin option in the uninstall menu so I’d like to start the script manually

nothing that can’t be fixed :wink:

do the following to get webmin available for uninstall

  1. execute the following on command line > nano /DietPi/dietpi/.installed
  2. change status of software titel 115 to 2 > aSOFTWARE_INSTALL_STATE[115]=2
  3. save & exit
  4. execute the following on command line > dietpi-software uninstall 115