web call from commandline

My website host provided Dynamic DNS and I have set up a sub domain
In order to update the dynamic IP address I use a web call


which autmatically links the home subdomain to the current public address of the calling PC returning that address, fine when there is a browser installed .

However, I would like to update it from a headless Raspberry dietpi installtion (where I use pihole, unbound etc.) on a remote site
I will be setting up a VPN to utilize it
Can anybody help.
Is there a way, in the command line, to call the web address without a browser, I’m not that interested in seeing the return page which is just for info (the IP adress used).

Thanks in advance


You can try to use dietpi-ddns. This offer a section to update public ddns provider using the custom section. I hope this is what you where looking for.

Thanks joulinar .
I looked at Diet-vpn, which required user login and password - something which is not required for my DDNs as the link contains all the info requred.
I entering user/password not required i.e. “0” but the setup failed.

I was thinking I may be able to use curl or wget to ‘get’ the webpage triggering the change.
Not sure which one I would use though.

Also not easy to check it works as I would need to change my public IP address requiring a router power down of 10 mins or so.
Therefore trial and error is not practical.

Why did you checked dietpi-vpn while you would need to use dietpi-ddns

woops typo - did check dietpi-ddns

however it looks like there is an issue with the server, I’ raised it with hosting tech support who are actually quite good.
After the first update, second one flags the same error with windows my browser. Problem was duplicated by tech support when they tried it.
So its safe to assumer the problem is at their end.

probably there is a limitation on how often you can update the DDNS entry? Or your get an error as the IP already match and there is no need to have it updated?

I considered that as a possibility but didn’t really make sense as it would be a standard requirement to check for changes.
Problem solved
Looks like it was an issue at the server (WHUK hosting), tech support fixed it with in the hour.
Can’t praise WHUK tech support enough, used them for many years, always fast respone and the online chat has helped me with a number of issues over the years.
Now I can use wget or easier dietpi-ddns (with no user or password) :slight_smile:
Joulinar, Thanks for your input

you are welcome

lucky guy, because dietpi-ddns is a brand new feature we introduced 2 weeks ago . Means, it’s highly appreciated if you see things not working and would report them :wink:

I wondered why I had not come across it before.
FYI this was for my own use.
I’m also going to use it elsewhere in conjuntion with a VPN.
Unfortunately, unlike WHUK, hostpapa does not support cpanel DDNS in the package used so going to try with a free DDNS service.
I will report back if it helps.

feedback is always welcome. Otherwise we don’t know what to improve and which services you guys like :sunglasses: