VS Codium

Hello everybody!

First time user of dietPi, on a Zero 2 W.

Thanks very much to everybody working on the project, I’ve enjoyed getting everything setup and running this week.

I have one quick question: I can’t seem to get VS Codium to work after install. Its icon appears on the desktop, but then nothing happens…

– I used the dietPi software manager which successfully installed everything else I requested, so not sure if there’s something I’m missing?

Happy to use nano, but just curious.

Thank you for any thoughts!

Hi could you fill the template pls. Maybe I could try to replicate

Required Information

  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)

Thank you for the reply!

Here is the filled out template:

G_LIVE_PATCH_STATUS[1]='not applicable'
G_LIVE_PATCH_STATUS[2]='not applicable'
G_LIVE_PATCH_STATUS[3]='not applicable'
root@DietPi:~# echo $G_DISTRO_NAME $G_RASPBIAN
bullseye 0
root@DietPi:~# uname -a
Linux DietPi 5.10.63-v7+ #1488 SMP Thu Nov 18 16:14:44 GMT 2021 armv7l GNU/Linux
root@DietPi:~# echo $G_HW_MODEL_NAME
RPi Zero 2 W (armv7l)

ok found the issue. Basically it’s an issue if you are running the desktop as root user. As root user a special argument would be needed to be able to start VS Codium.

root@DietPi3:~# /usr/share/codium/codium
[9483:0102/183539.798154:FATAL:electron_main_delegate.cc(252)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
Trace/breakpoint trap

something that could be bypassed but Codium will complain about running as user root :sunglasses:

FYI, should I open a GitHub issue on this? Or should we simply create a note on our online docs?

Okay got it - - so sounds like I should add a user, login that way, and then try codium – I’ll try that and report back.

Thanks very much for your help (and the project in general!).

To followup on this, I added a user w/sudo privileges and tried running Codium again from terminal. I didn’t get an error message, but unfortunately nothing opens.

I tried both when initially logging in from boot and after running desktop (lxde). With htop open I notice a momentary codium task running but it closes before I can read anything.

For me it was working using user dietpi. You need to login to a desktop to be able to start Codium. There you could open a terminal window and try to execute /usr/share/codium/codium