VPN status : DietPi-VPN is not configured! Please run: "dietpi-vpn"

Hi!

Was messing around with dietpi-vpn, just checking it out.

Now “dietpi-banner 1”, looks like a warning, that
VPN status : DietPi-VPN is not configured! Please run: “dietpi-vpn”

Searched hi an low but can’t figure out how to “unconfigre” vpn so this message goes away. Maybe it’s harmless and I can leave it as it is, but curious how to “get back” to how it was before when I didn’t see that in the banner. So, how?

Brgs,

Welcome to our community.

Did you tried to open dietpi-vpn. There should be a possibility to remove it.

Yes was in there too. This is what I see. Don’t see that I can remove stuff here.

dietpi-vpn

 Please choose your VPN provider:                                                    
                                                                                     
                                    NordVPN   : Connect to NordVPN                   
                                    ProtonVPN : Connect to ProtonVPN                 
                                    IPVanish  : Connect to IPVanish                  
                                    PIA       : Connect to Private Internet Access   
                                    Custom    : Use your own .ovpn file              
                                                                                     
                                                                                     
                                  <Ok>                                      <Cancel> 

How the dietpi-banner 1 look

 ─────────────────────────────────────────────────────
 DietPi v8.7.1 : 11:11 - Sun 08/21/22
 ─────────────────────────────────────────────────────
     _  _        _           _                    _      _
  __| |(_)  ___ | |_  _ __  (_)         __ _   __| |  __| |  __ _  _ __  ___
 / _` || | / _ \| __|| '_ \ | | _____  / _` | / _` | / _` | / _` || '__|/ __|
| (_| || ||  __/| |_ | |_) || ||_____|| (_| || (_| || (_| || (_| || |   \__ \
 \__,_||_| \___| \__|| .__/ |_|        \__,_| \__,_| \__,_| \__,_||_|   |___/
                     |_|

 - Device model : RPi 3 Model B (aarch64)
 - Uptime : up 4 hours, 51 minutes
 - CPU temp : 46 °C / 114 °F : Optimal temperature
 - LAN IP : 192.168.32.136 (wlan0)
 **- VPN status : DietPi-VPN is not configured! Please run: "dietpi-vpn"**
 - MOTD : DietPi v8.7 is here, check out the release notes:
          https://dietpi.com/docs/releases/v8_7/

Pls go into dietpi-banner and deselect VPN status. This should remove the entry

1 Like

Hi!

Yes, that made it go away. Many thanks and KUDOS for swift replies!

No need for an answer. Just still curious of the inner workings here in dietpi.
Ah, so it’s a false positive then. The option to show VPN status automatically becomes enabled when mocking around with dietpi-vpn even though one not completes the vpn config?

Honestly, I’m not 100% sure dietpi-vpn is going to activate the banner status. @MichaIng do you know?

Hi, just checking around here. func/dietpi-banner checks to see if aENABLED bit pos 13 i presume is set. This, what I can decode (not a coder) is the enable/disable if it should be shown at all.
Mentioned earlier was to reset and remove VPN. As I’ve not what I know of have configured VPN I tried doing so. Tested to go into NordVPN. In there I found the Option:

 Reset      : Remove and reset ALL configs and settings 

This was logged using the remove alterative.

root@ap-dietpi:/boot/dietpi/func# dietpi-vpn
[  OK  ] DietPi-VPN | mkdir -p /var/lib/dietpi/dietpi-vpn
[  OK  ] DietPi-VPN | curl -sSfLO https://downloads.nordcdn.com/configs/archives/servers/ovpn.zip
[  OK  ] DietPi-VPN | mkdir -p /etc/openvpn/nordvpn
[  OK  ] DietPi-VPN | unzip -o ovpn.zip -d /etc/openvpn/nordvpn
[  OK  ] DietPi-VPN | rm ovpn.zip
[  OK  ] DietPi-VPN | systemctl disable --now dietpi-vpn
[  OK  ] DietPi-VPN | rm -Rf /etc/openvpn/client.ovpn /var/lib/dietpi/dietpi-vpn /etc/openvpn/nordvpn /etc/openvpn/protonvpn /etc/openvpn/ipvanish /etc/openvpn/pia
[ INFO ] DietPi-VPN | APT purge for: openvpn, please wait...
[ INFO ] DietPi-VPN | None of the requested packages are currently installed. Aborting...
[  OK  ] DietPi-VPN | APT purge for: openvpn
root@ap-dietpi:/boot/dietpi/func#

dietpi-banner (text GUI) still show [*] for option 13 VPN Status and running dietpi-banner 1 still show the warning.

So just me poking around. Do’now if this gives any clue to what’s going on.
BTW, DietPi is an awesome solution. KUDOS to all gals and pals who is involved!

The dietpi-vpn script does not touch the banner options. So would always need to be done manually.

1 Like