VPN issues since updating to 7.1 IPV6 devices have no connection

Can someone please help me with an issue I’m having since updating to 7.1?

My instance is running pi-hole, transmission and sonarr. I’m using NordVPN, previously I’d set the vpn up with the dietpi-NordVPN command and everything was running fine.

Since that command was replaced with dietpi-vpn in the latest version im having issues, I’ve configured NordVPN again but when I connect I get a message about ipv6 being disabled this results in all my devices that use ipv6 not having an internet connection.

Is there a way to fix this? I didn’t have this issue before the update and I’d rather not have to set static ips on all my devices if I can avoid it.

Many thanks for your report.

Indeed IPv6 is disabled intentionally as NordVPN and ProtonVPN, actually most public VPN providers, do not support IPv6. As a result, IPv6 requests would bypass the VPN tunnel.

If you share the VPN with other clients in your network, then indeed those need to have IPv6 disabled as well. But there is no other way, I’m afraid. Leaking IPv6 requests would mean leaking a large portion of all connections, breaking the whole purpose of using the VPN.

Thanks for the reply, is there a reason it worked previouly though? Up until I updated to 7.1 all my devices worked fine when the pi was connected to NordVPN but now most of them don’t. I’m assuming it’s because I’m using pi hole has a dhcp server.

does your clients use IPv6 only?

Yes, it’s things like my Sky Q boxes I’ve never had to configure the network on them before I just pressed the button on the front of the box and the router and its worked fine for years.

I added NordVPN to my dietpi a few months ago it’s been been running 24/7 and never had any issues until I updated to 7.1

usually the SkyQ is supporting IPv4 and should be able to send DNS request to PiHole. You could have a look to PiHole log if you see the receiver.

The issue might be the VPN connection. Probably your SkyQ was bypassing the VPN before (due to IPv6). But this changed, and the receiver is now going to use the VPN. Maybe this is leading to issues as your SkyQ is now connection to the internet via VPN outside your home country.

This is quite some guessing :thinking:

I’ve tried disabling IPV6 on my sky hub and then I don’t get any internet connection on devices like my iPhone so I’m guessing it’s a Pi-hole issue because I’m not even trying to use the VPN now.

means NordVPN is disabled on your DietPi device?

To get some more inside on your DNS request, you could install tcpdump on DietPi and watch the DNS request, if they are arriving and getting answered upstream.

On you iPhone you could try to open a webpage like as this doesn’t involve any DNS.

Just been makiing some changes seems to be an issue from unbound, if I don’t use the custom server for IPV4 and instead switch to google everything works

Can you be a little bit more specific what changes you have done where?

In Pihole I was using a custom dns to point to the unbound instance running on my diet pi for ipv4 but if I unticked the no to use custom dns and used google ecs for ipv4 and ipv6 all my devices work and continue to work when connected to the vpn

Would be interesting to see what


is doing. Maybe it’s listen on the wrong interface, or sending DNS request to wrong gateway while connected to VPN. Best to install tcpdump and do some tracing