Very slow speed making a Backup on NFS share on Lan

I have tried to mount a folder that is on another machine with Ubuntu NFS server through Dietpi-drive_manager but I have not succeeded, looking for the share automatically, it was hung and ended up giving timed out error.

Then I tried to mount it manually with this line:

sudo mount -t nfs /mnt/nfs_client/Backup1

And if it has worked including it in Fstab. The line that I have included and that works is this: /mnt/nfs_client/Backup1 nfs rw,auto 0 0

In principle everything works correctly on two identical raspberry pi 4.
But when I run the backup, using dietpi-backup, it runs correctly but it took almost 5 hours. The speed between both machines is gigabit, tested with iperf, around 900mb/s.
Is this behaviour normal, can I improve it somehow?

As I understand the speed will improve in later backups because only the increments were used.

Thanks in advance :wink:

PD: this is the line in /etc/exports on the ubuntu server:

/media/WD.Cloud/Backup/1 *(rw,sync,no_root_squash,no_subtree_check)

PD: The speeds was around 350 kB/s

I am using async on the NFS server side.
Could you test it and compare the results?

ok, I have tested it and the speeds have improved a lot. My question now is what are the consequences of putting async? I think it’s less secure, isn’t it?
thanks in advance.

The first google hit e.g. gives a good explanation.,than%20immediately%20writing%20to%20disk.

Ok I should have done it, thank you, that explains everything :slight_smile:

1 Like