Very Slow Network Speed

I have 200/50 Mb broadband at home. The newly installed DietPi is lagging badly, so I ran the test on speedtest.net. I only got 10Mb of download speed. I don’t use wifi, but a cable instead.

I ran the same test on Libreelec (Kodi v18.9) with the same hardware setup. I got about 196Mb. What is going on?

Very strange.

If I run speedtest from terminal, the results are very close to my broadband speed which is 200Mb. However, if I run speedtest from their website via Chromium, I only get less than 10Mb.

Why? I can’t browse the web smoothly with this low speed. Please help.

Which board is this running dietpi?
Did you check cpu utilization while running the web speedtest?

Indeed. Issue could be with CPU utilization while running Chromium.

Yeah, CPU load is very high when Chromium is running, which I think is due to hardware acceleration is off. I have another thread for that question.
https://dietpi.com/forum/t/rpi3-hardware-acceleration-is-off/6132/1

If I’m not mistaken, hardware acceleration is used while playing videos only. This should not have any impact on running/ starting chromium itself. What board you are running? Maybe it’s to slow to run a modern browser.

I think so too.

You didn’t mention the board, but looking at this topic it seems to be an RPi3, which has a quad core 1,2GHz (or 1,4GHz for the plus models). Maybe there is lack of memory and the cache is used?

Happy new year!

It’s a RPi 3B+. Is it too slow to run Chromium?

It’s a plus model. It has only 1G of ram. Maybe that is a problem.

Have a look tohtop while running Chromium. How resource consumption is.