V6.24 Time won't synch after eth IP set to STATIC

Version 6.24.0

On Raspberry Pi 3B

Installed fresh image on SD
Booted up

Used dietpi config for adapters
saved and restarted networking
Boot up timed out trying to synchronize time

Rebooted, went back into dietpi config
Changed eth back to DHCP

Worked, but I need STATIC

Man, lost hours chasing this down!

No replies?

Where do I file a bug report? Obviously not here. Sorry! :anguished:

Perhaps an issue with the static DNS entry.

Which DNS nameserver did you enter when using static IP?
I suggest you try to simply use the IP of your router/gateway, which usually works.
Otherwise try (= Google DNS).

Another approach:

  • When chosen DHCP and verified everything works, do: cat /etc/resolv.conf
    The nameserver entry there is then known to work (assigned by the DHCP server/router), so you should be able to use it for static IP as well.

And last but not least:

  • Use your router/gateway IP as NTP mirror via dietpi-config > Network Options: Misc > NTP mirror > Gateway
  • But if indeed the DNS nameserver does not work, then you will just run into other issues since you cannot connect to any domain/host name then, just bare IPs.