V 6.0 on Native PC

Tried this last night on the Z83 - took a few reboots to get things rolling. Got round to installing a few things but on subsequent reboot the /DietPi folder was empty! It was getting late, I restored v159 which didn’t go that well as it exited with an error and PiHole didn’t work, but a reinstall fixed that.

Anyway thought I’d try again but by installing on external USB 3.0 flash drive and not eMMC. Got to the green DietPi install screen and there was no choice of where to install the OS to, so I stopped.

The questions is - does DietPi give a choice of locations to install to on these devices or is it eMMC only?


Tried again - confirmed there is not an option to install on any drive other than eMMC, or if there is I couldn’t find it. (Fourdee this would be a good addition to a future release? I have done exactly this with Liberelec which I installed on a USB flash after I had installed DietPi on the eMMC. Selecting the boot device you can choose which OS to run.)

Anyway on second attempt I got as far as installing Emby-Server successfully but attempting to install anything else stopped - the system stalled trying to mount efi drive (sorry should have written down exactly what was happening). Had to restore from v159 backup as the device is needed to keep the family entertained.

I may get a second Z83 to get this going.


This thing?

If so…that is soooo freeking awesome!!

Do you have another drive or is there only a emmc drive in it?

Just found this

It looks like there is a BIOS/CFM version, and a UEFI version…I think that Z83 (from the review/teardown video) says it’s UEFI

Also, might need to run dietpi-launcher, then select Dietpi-Drive Manager and see if you can mount that drive that way, then move all the user files to the external USB (from the video you could install a USB drive internally as well (there is an internal USB port [you have to pry the bottom of the case off])

Yes a Z83 but bought from Aliexpress - cheapest I could find (US $87) I think they are all pretty much the same inside.

It has 2x USB 2 and 1x USB 3. The version I have does not have an internal USB as far as I know. The ideal would be to preserve my current install and install v6 to a USB 3 flash drive. However as far as I can make out DietPi only installs to the eMMC. The Libreelec USB allows you to install to an external USB. So it can be done.

But - I suppose the existing files could be moved to an external USB and then, once working correctly, v6 could be installed to the eMMC?


Hi John,

Correct. You’ll need to edit the target device, before running the image:

NB: This ISO is for EMMC devices (eg: Z83-II) However, you can edit the following files for non-EMMC devices:
Edit /EFI/boot/grub.cfg, /syslinux/isolinux.cfg and /syslinux/syslinux.cfg and replace mmcblk0 with the name of your target hard disk, eg sda sdb etc.

Thanks for this Fourdee I’ll give it a go. If I get a working install on an external USB 3.0 drive it should be a relatively simple matter to move it to the eMMC later on? How would you advise doing it?


You’ll need to boot with Debian live on another USB stick, then run below to clone another USB stick install to EMMC.

dd if=/dev/sda of=/dev/mmcblk0

Assuming /dev/sda is the USB stick with installed DietPi. You can check file-system devices with


You may need to unmount the above before-hand and its partitions, due to automount on Debian Live.
eg: check mounted with:

df -h

Then unmount, eg:

umount /dev/sda1

Thanks again Fourdee - using this method will I need to edit the fstab file in its new location?

For example will these entries (from my v159 setup)

UUID=CA7A-8CED /boot/efi auto defaults,noatime,discard 0 2
UUID=e1efd31c-5b47-4db1-b600-7954f833f9f5 / auto defaults,noatime,discard 0 1

Need to be changed?


Fourdee - tried this method but it didn’t work - here’s a link to a photo of the screen:


I had the installer image on a USB flask with the target for the OS being an ext4 formatted USB 3.0 32 GB in the USB 3.0 socket.

I tried sda, sdb, sdc - all the same.

The install runs a bit more after the screenshot then powers off.