Using Deluge for Thin Clients

Hey,

I’m trying to get Deluge to run as a server for a client on Windows, I can get the DietPi install to connect when I add user:password:10 to the end of the auth file, installing deluge-console and allowing remote access. But after reboot I have to restart deluged for the client to able to connect.
I’ve also tried this guide that installs Deluge.1.3.11 but I couldn’t get the boot script to work on DietPi. Although the cron script worked a few times.

How would I go about getting the DietPi to start deluge at boot but not have to restart deluged to connect a client? And could this be made into an install option or a dietpi-config option please?


Thanks.

Hi,

Did you follow the “After Installation (1st run):” guide here: http://dietpi.com/phpbb/viewtopic.php?f=8&t=5&start=10#p61

All you should need to do is enable the remote connect in the deluge conf file.

Can you give me the link to the windows client your using? I’ll run my own tests also.

Yes I went through the first run setup, but that doesn’t take either, have to restart dietpi-services to be able to login in with “raspberry”.
I’m assuming by conf file you mean the core.conf, but there’s two /root/.config/deluge/ or the one in /.config/deluge/? Also I’m using Deluge 1.3.11, not in classic mode, on Win7 as the client.

Hi Crazi,

I’ve improved the DietPi-Software deluge installation for our next release (v87):

  • deluge-console is now installed by default (allowing remote access from desktop clients)
  • Removed the “1st run setup” steps as they are no longer required.

I tested with Win7 on my deluge desktop client today. works a treat :slight_smile:

When v87 is released (will be later today):

Hi
I installed Dietpi as I hoped to be able to get things set up simply after running into major problems setting up a torrent box with VPN on Raspian. However I am still having problems with Deluge on Diet pi.
I followed the instructions you posted and have tried to access deluge with Thinclient from my windows PC.
I managed to log in with 127.0.0.1 with admin and raspberry as you show in tutorial but that doesnt give me access to the USB drive where my folders reside. I did (somehow) manage to log in with my Pis IP address but now that fails and I can’t connect. What password should I be using and how can I get access via my pi s IP address please.

Edit: I tried accessing via the web client and that wont accept raspberry as login either so I cannot connect! I realise I just updated to version 88 from version 87. Could this have something to do with it?

Hi Hungryguy,

If your accessing a terminal, or console:
username = root
password = dietpi

Deluge login:
As per this link http://dietpi.com/phpbb/viewtopic.php?f=8&t=5&start=10#p61

There may be other issues (eg: network). Ideally, if you could send me a bug report, i’'ll be able to look into this further.

To send a bug report:
run dietpi-bugreport and follow the onscreen instructions. Please post your reference CODE here.

Thanks , I know how to log in to the pi, It’s deluge I cant log in to despite following your instructions the logins arnt accepted. The web Gui for deluge says password not accepted.
Here is the bug report reference code : b827ebc714cd-0

Thank you for your help

Hi,

I did a fresh install today of Deluge, was unable to replicate the issue, so it could be client side.

The IP address of your Pi is 192.168.1.169.
Please try the following:

  • open up this link http://192.168.1.169:8112
  • select the 127.0.0.1 address
  • click connect
  • Try the password raspberry. If this fails,
  • Try the password deluge

If the deluge password lets you in, close the window and run the following on your RPi:

echo -e "admin:raspberry:10" >> ~/.config/deluge/auth
/DietPi/dietpi/dietpi-services restart

Then try to reconnect using the password raspberry

Please let me know the results of the above. If there are any errors, add those aswell.

Kind Regards,
Dan

[quote=“Fourdee”]Please try the following:

  • open up this link http://192.168.1.169:8112
  • select the 127.0.0.1 address
  • click connect
  • Try the password raspberry. If this fails,
  • Try the password deluge[/quotecan ]

Hi

I managed to log in using deluge password on the web page but cant log in using admin:raspberry despite running your code.

Anything else I can do?

Hi again.

Well googling this website:http://www.howtogeek.com/142044/how-to-turn-a-raspberry-pi-into-an-always-on-bittorrent-box/ and following that
I have managed to gain access to deluge via user:admin and pass:raspberry .
However I now still cannot connect to my USD HDD to save the files. Dietpi setup these folders on the USB HDD automatically so how /what do I need to do to get deluge to recognise themand use them for downloading?

Hi Hungryguy,

Ideally, if you can, i would recommend writing a fresh DietPi image. I’ve just done this my end, everything works, and its automatically setup to use my external HDD.

Alternatively, you should be able to change the download location from the Deluge web interface:

  • Click preferences
  • Click downloads
  • use /mnt/usb_1/downloads as the location