Using Chromium in Kiosk mode on a touch screen and don't want new tabs opened

I’m using Chromium in Kiosk mode on a touch screen for an art exhibit I’m curating. I built a simple website that has links to various websites that I’m exhibiting. When you tap these website buttons, it changes the current tab to that website which allows the user to drag backward to switch back to the hub. The problem is, some of these websites lead to other websites that open up new tabs. This means the new tab now takes over the screen and the user can no longer swipe back because they’re in a new tab. Is there a way to lock Chromium so that it either blocks new tabs, or just locks its focus to the first tab?


Hmm, I’m not sure whether the --app mode (as alternative to the --kiosk mode changes something about that, but generally whether a link opens in a new tab or on the same tab is defined by the related HTML attribute. In an <a> tag with target="_blank" the website forces a new tab, and I’m not sure whether it’s possible to force it using the same tab as user.

1 Like

Thanks for the input. This is what I was afraid of. I’m wondering if maybe I can just block all websites other than a specific list. Do you know if that’s a possibility in Chromium?

Probably there is an app in the Chrome store? Otherwise even if you use firewall or route rules for this, the new tab will still open, just with an error. So you would require an app which prevents the links to be opened at all, i.e. ignoring the links completely if the target does not match the white list. If such exists it would be also better (if it only blocks links, no requests) since then external resources from a website can still be loaded without adding all those related hostnames to white list/rules as well.

But more likely is an app or option to force all links to be opened in the same tab, I think.

1 Like

Yes there is an extension for chrome which can block new tabs, but it is from 2018, so no guarantee it’s still working.


Awesome! I’ll give this a shot. I’m having trouble accessing the extensions settings page in chromium, but I’m guessing I need to turn off kiosk mode, set it up, and turn it back on. Anyway, this is hopeful. Thanks.