userdata folder lost

i previously moved userdata to external usb. Which then crashed.
Now i cannot update diepti because “DietPi was unable to verify the existance of the userdata directory │
│ (/mnt/usb8gb/dietpi_userdata)”

I tried going to disk management and transfer userdata to a healthy disk but till gives me error and i cannot proceed.
Is there a way to manually recreate userdata folder somewhere?
I don’t want to start from scratch as i have a lot of software already setup on my diepti.

You mean the userdata transfer to the external drive went through without issues first, but the drive crashed afterwards? Because we only remove the original userdata when the copy went through without error.

If the copy/transfer itself broke, then the userdata should still be placed at /mnt/dietpi_userdata.
If the drive broke afterwards, I would run some fsck on it, e.g. open dietpi-drive_manager, select the external drive/partition, select Check & Repair. Hopefully it can be mounted successfully afterwards.

If it is not recoverable on the external drive, I am afraid it is lost. It makes sense to always have a backup in place, especially when doing things like transferring root oder userdata to an exernal drive. Did you probably create a dietpi-backup previously, e.g. as choice when some DietPi-Update prompt on software reinstall?

Thank you. USB is totally destroyed.
i found this backup folder but cant seem to find userdata inside

I’m sorry for that. That’s the reason I run a backup of important user data and config every night.

Userdata is in /mnt/dietpi_userdata.
Which software titles did you have installed? Probably we can recover some configs as well.

It’s outside of Dietpi supported software.
Specifically - Ambilight and HBO GO and Netflix for Kodi

Nevermind now. I’ll start from scratch.:slight_smile:
Appreciate you jumping in and try to help!!!

just one more question i believe my userdata was empty anyway and to me not important , as system is working flawlessly without it. i just want to pass that error and update dietpi, still cannot recreate it manually?

Ah okay if it was empty anyway then there is no issue. As long as you don’t install certain software via DietPi scripts it is indeed not used. Simply run:
mkdir /mnt/dietpi_userdata
chown dietpi:dietpi /mnt/dietpi_userdata
Not sure if either the symlink needs to be removed first or the command need to target the actual external drive location otherwise, since they might but follow symlinks :wink:.

That worked!
Thank you!! :sunglasses: