USB-HDD not allow me to write. it is only Read only in EXT4

I want to use my Raspberry pi with USB-HDD as main storage as well as RootFS. But i am struck, my USB-HDD always become a read only drive on EXT4 format. It is working fine with read & write on FAT32, NTFS, BTRFS format. I want complete HDD used for Linux so EXT4 only type of format in all HDD. I did fresh install of Rasbian Lite & Diet-PI but both system give me same result. So please help me help me to jump this hurdle. After partitioning with GDisk in EXT4. i gave following commands:-

sudo mke2fs -t ext4 -L my_hub /dev/sda1
sudo mkdir /mnt/my_hub
sudo chmod 777 -R /mnt/my_hub
sudo mount /dev/sda1 /mnt/my_hub
So after these commands HDD attached to this location “ /mnt/my_hub” but with read only. If same procedure i adopted with BRTFS drive format everything work correct HDD gave me both Read & Write capability. So i am struck somewhere in Linux permissions.
I also tried to use Dietpi inbuilt function for Transfer RootFS to USB but was unsuccessful. If in this function i used EXT4 format then RSYNC command not able to write any thing on HDD. So only Lost and found folder in HDD. If i used BTRFS format then i am able to see files copied to HDD but system not able to reboot & system hault in booting & give me this error “Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)”
So both automated & manual way have not working for me. Please help me. thanks

have you used the dietpi-drive_manager command to mount the device?

Thanks everybody for helping me. I put HDD in different enclosure, and repeat above guided procedure then system working fine. So may be old enclosure having some compatibility issue. Thanks all for guiding me.