Urbackup file permissions not working (Code 13)...

I’m having trouble with Urbackup accepting the file permissions of my network drive. I’ve set up Dietpi using Samba to point to a folder on my networked drive on my Buffalo LS421DE server, but I keep getting the error code 13.

I thought that it may be that the file permissions on the folder on my Buffalo server, but these are set to 0777, so there is full access. But when SSH into the Samba folder on my Dietpi, it is set to 0755. I have tried to change this, as root, to 0775, but even as root, it wont keep any changes. I thought that logged in as root, I have full administration rights, but this does not seem the case for the Samba folder.

Is there something I’m missing?



I’ve been having the same issue. Any ideas?

I had today same issue, and solved it as follows:

Outgoing Situation: (fresh install, 5 minutes ago)
When you follow the manual on Dietpi Software Urbackup,
you should change the backup storage path. After changing the storage path take a look at the old and new path by ls -al

Old Path:
new path + solution:
Just restart service with dietpi-services restart