Upload backup permission denied

hi all having problems with dietpi install of Filebrowser and permission when uploading
did try a docker and had no problem with upload

uploaded a docker container same folder /dietpi_userdata with no problems with upload

root@DietPi:~# journalctl -u filebrowser
-- Journal begins at Fri 2022-07-22 14:17:55 BST, ends at Fri 2022-07-22 14:45:32 BST. --
Jul 22 14:18:01 DietPi systemd[1]: Started File Browser (DietPi).
Jul 22 14:18:01 DietPi filebrowser[484]: 2022/07/22 14:18:01 No config file used
Jul 22 14:18:01 DietPi filebrowser[484]: 2022/07/22 14:18:01 Listening on [::]:8084
Jul 22 14:26:53 DietPi filebrowser[484]: 2022/07/22 14:26:53 /dietpi_userdata/volumes/data/custom_components/heatmiserneo/const.py: 403 mkdir /mnt/dietpi_userdata/volumes/data: permission denied

don’t understand the problem

maybe you can share the permissions you have set for these folder

ls -la /mnt/dietpi_userdata/volumes/data
1 Like

how do i change permission then

drwxrwxr-x 10 dietpi      dietpi 4096 Jul 22 14:36 .
drwxr-xr-x  6 root        root   4096 Jul  3 16:38 ..
drwxrwxr-x  2 dietpi      dietpi 4096 Jul 22 16:41 Music
drwxrwxr-x  3 dietpi      dietpi 4096 Jul 22 16:41 Pictures
drwxrwxr-x  2 dietpi      dietpi 4096 Jul 22 16:41 Video
-rwxrwxr-x  1 filebrowser dietpi 2975 Jul 22 14:08 docker-compose.yml
drwx--x--- 13 root        root   4096 Jul 22 14:45 docker-data
drwxrwxr-x  3 dietpi      dietpi 4096 Jul 22 16:41 downloads
drwxr-xr-x  2 filebrowser root   4096 Jul 22 07:00 filebrowser
drwxr-xr-x  3 root        root   4096 Jul 22 12:48 filebrowser_docker
drwxr-xr-x  5 root        root   4096 Jul 22 14:37 volumes

here is the terminal after pasting ls -la /mnt/dietpi_userdata/

As you can see, folder volumes is owned by root user and root is the only one who could write on it. Not sure what else is located on the directory but you could change everything to be owned by user filebrowser. This way, filebrowser would be able to write on it.

chown filebrowser:filebrowser -R /mnt/dietpi_userdata/volumes/

Hello, I also have that problem. I cannot do anything because 403 permission error. I don’t want to change permissions for my folders because other apps use that. OK, I fix that.

Second is how to add other folders like /home/dietpi/ because Filebrowser shows only /mnt?

You need to add the user which runs filebrowser to the group who owns the folder, you don’t have to change your permissions.

You can add folders via the webUI, but again you have to make sure that the user, which runs filebrowser has write access for this location.

Best to my knowledge you can specify a single root folder only. That’s where File Browser will start. To see all folders, you might need to change configuration to root folder / as starting point.

/opt/filebrowser/filebrowser config set -r /

Hi that don’t help

dietpi@DietPi:~$ sudo /opt/filebrowser/filebrowser config set -r /
Sign up:          false
Create User Dir:  false
Auth method:      json

  Files override:          
  Disable external links:  false

  Log:           stdout
  Port:          8080
  Base URL:      
  Root:          /
  TLS Cert:      
  TLS Key:       
  Exec Enabled:  false

  Scope:         .
  Locale:        en
  View mode:     list
  Single Click:  false
    By:   name
    Asc:  false
    Admin:     false
    Execute:   true
    Create:    true
    Rename:    true
    Modify:    true
    Delete:    true
    Share:     true
    Download:  true

Auther configuration (raw):

  "recaptcha": null

dietpi@DietPi:~$ sudo dietpi-services restart filebrowser

 Mode: restart filebrowser

[  OK  ] DietPi-Services | restart : filebrowser

What did not helped? File Browser should start on root level now.

No it’s still the same folders from /mnt. Do I have to login as root? Because I login with dietpi and global password.

Did you restart the service after the changes were made?

Yes, You can see that im previous post.

I login as user root and following is working for me

cd /mnt/dietpi_userdata/filebrowser
systemctl stop filebrowser.service
/opt/filebrowser/filebrowser config set -r /
systemctl restart filebrowser.service
1 Like

Thanks, now works :slight_smile: