Updating Emby Server manually - felt a bit too easy


So as I understand Emby is linked to the repo here: http://download.opensuse.org/repositories/home:/emby/Debian_8.0/

Hence Apt won’t update past So I did some digging. And had a go updating manually. Steps:

  1. Downloaded latest Emby server from official site and copied it to the DietPi local filesystem.
  2. Ran:
dpkg -i emby-server-deb_3.5.3.0_armhf.deb
  1. Done.

I rebooted. And et voilà, opened Emby’s web interface and I’m running the latest version.

Normally when I embark on these tasks it takes all night. But this worked really easily, no errors, no weirdness. Just worked. :sunglasses:

I guess time will tell as I use Emby, but is this the correct method/safe?


My suspicions were correct. I couldn’t get the Library to scan for new content.

It appears installing in the above method caused the file paths to get confused. Rolled back for now.

I sometimes do it this was and have never had a problem. The other option is to wait and it comes in through doing apt-get update/upgrade.


Mmm, interesting. Did you initially install Emby Server via the GUI, or manually with the package from the Emby?

I think where I may have gone wrong is initially installing via the DietPi optimized software list, then updating manually.

I installed it through the dietpi-software menu.

Same as me then. I’ll have a play when I get some time. Cheers.

On current DietPi, the emby-server version installed via dietpi-software is v3.5.2, not the APT repo version. This is at least since DietPi v6.15.
Running APT should not overwrite this version with an older one.

We do no manual adjustments, so manual install, as you did, should work without issues. Will test v3.5.3 and update dietpi-software install, if everything works fine.

Which device do you use and could you post the error messages you face, when trying to scan for media?

Ah the older installs updated through APT.

But anyway maybe rebuilding the library will fix this?


Thank you both.

MichaIng, my understanding was wrong as I was following this (now) outdated info, which I found whilst Googling:

That was why I mistakenly thought the DietPi optimised software install method would be stuck on for now. I’ll keep an eye out for 3.5.3 if your testing goes well. Cheers.

johnvick, I unfortunately nuked everything and started again (short of time, wife wanting to watch something rather than me tinkering…). So can’t test this or pull any error messages. Apologies. The errors may actually have helped get some sort of answer too.