Updated PiVPN now SSH connection refused

I’ve been (happily) using DietPi for awhile now. I was having some trouble with PiVPN so I decided to uninstall/reinstall to make sure everything was up to date.

Uninstall worked fine. Rebooted. Worked fine. After rebooting from the reinstall, however, I no longer have SSH access. To make matters worse, I’m travelling (in Europe, live in America) and don’t have physical access.

Any ideas or backdoors of sorts? I had something similar happen in the past like that (on Raspbian) and I was able to VNC in and use the terminal from there. I’m not sure what’s installed by default on DietPi but VNC didn’t seem to work so I assume it isn’t. I can connect to other computers from the local network and they’re getting rejected by it too, so I’m positive it’s not a routing thing. And I have a web server that’s currently running on it so I know it’s booted.

:thinking:

Might have someone power cycle…I know occasionally mine hangs on reboot…

So, I did have someone power cycle (as per your suggestion), but no luck.

I just got back and hooked it up to a monitor. Looks like somehow the SSH server was uninstalled. Reinstalled it and everything works again.

uninstalled?! wow…that’s weird

I had mine get all wonky but not uninstalled