Update failure Odroid HC1


i would likte to update version 7.5.2 to 7.6.2 an get this issue:

Additional logs:

Hit:1 https://deb.debian.org/debian buster InRelease
Hit:2 https://deb.debian.org/debian buster-updates InRelease
Hit:3 https://deb.debian.org/debian-security buster/updates InRelease
Hit:4 https://deb.debian.org/debian buster-backports InRelease
Hit:5 https://dietpi.com/meveric all InRelease
Hit:6 https://dietpi.com/meveric buster InRelease
Error: No information about packages! (Maybe no deb entries?)
Reading package lists...
E: Problem executing scripts APT::Update::Post-Invoke-Success 'test -x /usr/bin/apt-show-versions || exit 0 ; apt-show-versions -i'
E: Sub-process returned an error code

What can i do to fix it?


Hmm you could try to disable apt package compression and clean cache.

echo 'Acquire::GzipIndexes "false";' > /etc/apt/apt.conf.d/98dietpi-uncompressed
/boot/dietpi/func/dietpi-set_software apt-cache clean
apt update

Thank you very much. That fix the issue!


I have the same problem (I don’t know how to solve it (please help, because the commands above did not help me …
I already tried reinstalling dietpi several times and then over time I got an error with apt-show-versions


Do you require apt-show-versions? It was once installed as dependency with Webmin, but is not required anymore, the alternative native apt command is even faster and provides more details in the Webmin GUI.

So if you don’t use it for something specific, I suggest to purge it:

apt autopurge apt-show-versions
apt update
1 Like

tried, but still gives some error …

open screenshot

As you can see on your picture. Purging the package is already failing. Therefor it doesn’t make sense to continue as long as this has not been fixed.

Let’s try to fix the broken package

sudo mv /var/lib/dpkg/info/apt-show-versions.* /tmp/
sudo dpkg --configure -a
apt autopurge apt-show-versions
sudo apt update

No need to continue, if it fails on one step

BTW: there is no need to do screen prints, you simply could copy the whole output from SSH terminal. If the output is to long, you could create a log.txt file and attached it to your post.

While this workaround allow the purge to finish, all files will be left in place so that related errors remain. So the package needs to be reinstalled and purged once again to have it fully removed:

apt install apt-show-verions
apt autopurge apt-show-versions
apt update
1 Like




This was meant as an addition to the steps provided by Joulinar above. However, since there are no package lists created (it seems), you need to addituonally do this first, so the apt update can succeed once:

rm /etc/apt/apt.conf.d/20apt-show-versions
apt update
1 Like

also error(

open screenshot

Could this have something to do with updating webmin or the dietpi system itself?
It’s just that I haven’t had such errors over the past 4 years, but only after I updated it, and then reinstalled it several times from scratch, this error pops up over time (
I already think that this may be a problem in the sdcard itself which I have on 16gb, although this is unlikely, I did not have errors when writing the dietpi image…
I don’t even know what the problem is…

*p.s. I want to note that I could not install webmin itself with dietpi-software, it immediately gave an error, I had to manually install it, I think it’s all to blame for updating dietpi or webmin

This is something new)

open screenshot

Yes, now do the steps provided by Joulinar above, followed by the steps I provided below those. Then you should be fine to update and install whatever you like :slightly_smiling_face:.

1 Like

Is everything okay on my last screenshot?
do I not need to re-install apt-show-versions?)

Yes you do. The file list of the package was corrupted (dedicated issue) so to be able to cleanly uninstall it, it needs to be reinstall first to not have loose files on your system.

1 Like

thank you very much friend!)
Greetings from Ukraine!) :wink:

Then I additionally hope that you and your family are staying safe :pray:.


@doc2g does this has been solved now?

Those commands that MichaIng advised to perform, so solved my question.