Update 154 - 155 fails


i try to update my Raspberry Zero W from 154 to 155.

Updates from 152-154 worked flawless.

Update 155 is signaled.

dietpi-update = Run now to update DietPi (from V154 to V155).

i can ping from the dietpi (154)

root@DietPi:~# ping -c 1 dietpi.com
PING dietpi.com ( 56(84) bytes of data.

root@DietPi:~# ping -c 1 fuzon.co.uk
PING fuzon.co.uk ( 56(84) bytes of data.

update process:

Mode: stop
Please wait…

[Ok] cron
[Ok] lighttpd
[Ok] php5-fpm
[Ok] dnsmasq
[Ok] pihole-FTL

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (6) Could not resolve host: dietpi.com
[Failed] Download failed, unable to run update. Please try running dietpi-update again.

lighttpd is down

service lighttpd status

Sep 04 18:16:58 DietPi systemd[1]: Stopped Lighttpd Daemon.

i have to restart the pi to get everything to work again.

What should i check to get this update to work?

Thank you!


Looks like a DNS issue. Might be due to PiHole service being stopped.

Whats the DNS server setting in dietpi-config > Networking Options > Ethernet?

Hi Fourdee, thank you for replying so fast.

this is the setting for

Ethernet Adapter

  No Ethernet Hardware was found. You are most likely     │ 
                     │ running a Pi Model A.

Wifi: Available | Enabled | Connected

Current Details:                                             │ 
                  │  - SSID    = NAME | 65 Mbit | Strength: -28 dBm            │ 
                  │  - KEY     = PASSWORD                         │ 
                  │  - Mode    = STATIC                                           │ 
                  │  - Ip      =                                     │ 
                  │  - Mask    =                                    │ 
                  │  - DNS     =

after the update stops ([Failed] Download failed, unable to run update)

i get this feedback in terminal:

root@DietPi:~# pihole status
::: DNS service is NOT running
root@DietPi:~# pihole restartdns
root@DietPi:~# pihole status
::: DNS service is running
::: Pi-hole blocking is Enabled

root@DietPi:~# service lighttpd status
● lighttpd.service - Lighttpd Daemon
   Loaded: loaded (/lib/systemd/system/lighttpd.service; disabled)
   Active: inactive (dead)

Sep 04 18:22:12 DietPi systemd[1]: Starting Lighttpd Daemon...
Sep 04 18:22:13 DietPi lighttpd[1159]: Syntax OK
Sep 04 18:22:13 DietPi systemd[1]: Started Lighttpd Daemon.
Sep 04 22:56:00 DietPi systemd[1]: Stopping Lighttpd Daemon...
Sep 04 22:56:00 DietPi systemd[1]: Stopped Lighttpd Daemon.

I hope this contains something useful, thank you for your help.


Ip =
Mask = │

you need a propper working wifi network configuration, with correct default gatway and working dns server.

Go to dietpi-config > Networking Options > Wifi and set it correct for you LAN.

Hi k-plan,

Wifi connection is working, im able to install via apt-get, ping dietpi.com, install pihole blocklist updates.

Dietpi 154 is working, the update to 155 fails…

Before i start dietpi-update i turned pihole off

This is my last try, before I give up forever …

Hi sofad,

Dir ist aber schon klar, dass die IP: ein spezielle IP Adresse ist?
Loclahost, Loopback-Device, localnet, wie auch immer du es nennen willst?

Wenn du per Hand pihole anhälst oder wenn dietpi-update VOR dem Update ALLE laufenden Dienste beendet via dietpi-service und somit auch pihole, hat dein Geräte KEINE funktionierende Namensauflösung (vallid DNS-Server) mehr.

Folglich kann dietpi-update nur fehlschlagen …

Du brauchst unter Wifi Network in dietpi-config, AUCH wenn du pihole installiert hast und besonders dann, eine funktionierende Netzwerk Konfiguration zu Beispiel:


Warum in alle Welt auch immer , dort jeder eintragen will oder eingetragen hat, ist mir vollkommen schleierhaft … :roll_eyes:

thank you k-plan

i tried to set static_dns to


i apply and save changes, restart networking

the static_dns is still


after i uninstalled pihole the static_dns is set to and update is working

reinstalled pihole.

thanks for your help


Hi, still having exactly the same problem trying to update form 156 to 157

The only way I could update was by uninstalling pihole, after that it worked without issues.


I had the same problem updating from V156 to V157.

I could avoid uninstalling pihole by adding # to the beginning the lines in the dietpi-update script, which stop the services, changing them to comments, so it didn’t stop the services during update.

Every thing works fine so far…