Universal time not in sync with NTP

Unable to remove or sync Unviversal time…running latest DietPi

root@DietPi:~# timedatectl status
               Local time: Sat 2024-03-02 16:37:51 PST
           Universal time: Sun 2024-03-03 00:37:51 UTC
                 RTC time: n/a
                Time zone: America/Los_Angeles (PST, -0800)
System clock synchronized: yes
              NTP service: inactive
          RTC in local TZ: no




Command 'status' not found, did you mean:
  command 'states' from deb enscript (1.6.5.90-3`Preformatted text`







#### Required Information
- DietPi version | 9
- Distro version | Bullseye
- Kernel version 6
- Architecture | `dpkg --print-architecture`
- SBC model | RPi3)
- Power supply used | canakit
- SD card used | (EG: SanDisk ultra)

#### Additional Information (if applicable)
- Software title | (EG: Nextcloud)
- Was the software title installed freshly or updated/migrated?
- Can this issue be replicated on a fresh installation of DietPi?
<-- If you sent a "dietpi-bugreport", please paste the ID here -->
- Bug report ID | `echo $G_HW_UUID`

#### Steps to reproduce
<!-- Explain how to reproduce the issue -->
1. ...
2. ...

#### Expected behaviour
<!-- What SHOULD be happening? -->
- ...

#### Actual behaviour
<!-- What IS happening? -->
- ...

#### Extra details
<!-- Please post any extra details that might help solve the issue -->
- ...

What exactly is your issue? Pacific Standard Time is 8 hours behind Universal Time Coordinated. Means, displayed time seems to be correct.

1 Like

ok thxs, didnt know that. I had updated Dietpi and Pihole and next day I lost internet. After some torturous hours of troubleshooting, I determined the time sync was the issue. After setting time, all was good. I do notice in piHole web UI, the time is using UTC…

Usually the time should be updated once a day. Can you take a look at the logs?

journalctl -u systemd-timesyncd.service
1 Like

no all good. I have ntp on recommend setting …also I just found why Pihole reports UTC, was a resist fingerprinting add on…