[Unable to replicate] NanoPi Neo2 Ethernet Speed dropping?

Hi there!

New here on the forums and would like to seek some help on the matter.

First, my setup details:
SBC : NanoPi Neo2 512MB, with Nanopi specified heatsink (NPiN2)
OS : DietPi v6.15 (upgraded from v6.12) in 8GB class10 microSD
PSU : 5V 3.0A, microUSB cable rated 2.4A
Network : Ethernet LAN connection using CAT6 cable, connected to gigabit Ethernet switch
USB HDD : 2.5" Seagate Barracuda 2TB in Orico SATA to USB3.0 HDD case, using JMicron Chipset

 DietPi     | 07:13 | Mon 17/09/18 
 v6.15      | NanoPi NEO 2 (aarch64)
 eth0       |
root@DNanoPiNeo2:~# lsblk
sda           8:0    0  1.8T  0 disk 
└─sda1        8:1    0  1.8T  0 part /hdd
mmcblk0     179:0    0  7.5G  0 disk 
├─mmcblk0p1 179:1    0  100M  0 part /boot
└─mmcblk0p2 179:2    0  7.1G  0 part /

The unit above is mainly used as NAS and torrent box, using Deluge client.

This unit is running together with another torrent box based on Raspberry Pi Model B+ rev 1.2 (c) 2014 (RPi1B+), running Raspbian stretch with desktop. Identical USB HDD used, connected to the same gigabit Ethernet Hub switch. Torrent client is also Deluge on this RPi1B+ with settings (preferences) an exact copy of the settings in NPiN2-DietPi setup (well…except for the download directories)

I was extremely happy when I first tested the NPiN2-DietPi download speed after the initial setup (back then it was v6.12). It was way faster than the RPi1B+ setup. It was really taking advantage of the Gigabit ethernet port.

Second: The problem
As both are running in parallel, I noticed that the download speeds on the Gigabit NPiN2-DietPi drops after sometime. making it slower than those on the 100Mbps RPi1B+. Even if I change the download order on the NPiN2-DietPi, the download speed remains slow (average 600~650kbps vs. average 1.0Mbps on RPi1B+).

Things tried to fix the problem:
First I thought that maybe the DietPi OS needs to be upgraded, so I did an upgrade from v6.12 to v6.15, but that did not fix the problem.
Also tried changing the LAN cable of the NPiN2 to thicker CAT6 rated cable, but no effect.
Also tried to connect the USB HDD to NPiN2 via powered USB2.0 hub, no effect.

As of now, the download race between NPiN2-DietPi vs RPi1B+ is always won by RPi1B+ (which is supposed to be much slower than NPiN2)

The question:
a. Are there any setting(s) that I need to modify to in order for the NPiN2-DiePi to maintain taking advantage of the Gigabit port?
b. Any pointers in order for the NPiN2-DietPi to regain download supremacy over RPi1B+?


Unofficially conceding defeat?

Maybe after 1 week and no replies to address the problem then I guess I can consider it to be official…

What kind of speeds are you pushing?

Thanks for the “bump”

Well during the early phase of usage, the NPiN2-DietPi-Deluge (N-D-D) setup was averaging 4.5Mbps which was great and had my hopes up, compared to the RPi1B±RaspbianStretchDesktop-Deluge (R-R-D) setup that was only averaging 1.0Mbps.

From the time I posted and to this day, the N-D-D is now averaging from 600 to 750kbps, the R-R-D maintains at an average of 1.0 Mbps.

N-D-D always looses…

So it got me wondering why the quad-core GbE equipped NPiN2 with could be loosing so badly to a Fast Ethernet (100BASE-TX) equipped single-core RPi1B+

Here is what I got from the friendlyarm forum when I posted an exact copy of the first post there…

by igorp » Sat Sep 22, 2018 6:07 pm

FriendlyARM doesn’t provide support for Dietpi. That is official - check the wiki.

Does this mean that the culprit might be DietPi OS? :thinking:

Officially dropping the project due to no fix provided to solve the problem stated in first post

Thanks for your report and sorry for the late reply.

Do you have NanoPi Neo2 device there to try replicating?

Of course FriendlyARM cannot officially support all 3rd party distributions. It makes sense that we first try to replicate and check for DietPi related issues. Only if we can sort out it is due to DietPi, outdated kernel version and such, we can forward the issue to FriendlyARM/NanoPi forums.

The main issue here is all tests are done using internet downloads of bittorrents, shared between two devices which the router may prioritize as it requires.

Many open connections on a router, might also be a causing factor. Cheap routers will struggle to handle > 25 open connections.

Ideally, tests should be done on a local bittorrent server, to exclude external networking from the cause.

Another factor is if both machines have the same hostname, the router might be getting “confused”. Unlikely, but you never know.

I will setup a NEO2 + SSD and test deluge under download speeds.


  • NanoPi NEO2
  • 100mbit internet
  • 13MB/s write speed on USB pendrive (all i have available)


  • 6-9MB/s download speed on a shared connection, which also runs another Transmission client, and misses streaming TV/movies

Unable to find any issues.

If network bottleneck is not the issue, I can only suggest ensuring a stable 5V/2A PSU, if the USB drive is bus powered. Check dmesg for any issues relating to USB drive and power:


Also, run a benchmark on the USB drive (dietpi-drive_manager), to ensure the controller/drive is not at fault.