Unable to install DietPi on an old PC

Hello Everyone,

I’m new here, but I have been using DietPi on my RPi as FTP, Pihole and other useful stuff.

I am able to build a repurposed PC as a Server. And soon as a File Server to have shares both locally and outside our home, once DietPi is installed.

I’m ready to make this project, however installing it is the hardest part. I am able to make a bootable drive using Rufus, but it seems hard to boot to it. I am using the BIOS image version of DietPi and not the UEFI, as I am sure this PC is not capable of supporting UEFI.

Do you have an idea on how to make this .img work on my PC? I’ve tried both rufus and etcher and it’s not working. Although it boots, but not where you can select any option to install DietPi. It’s just errors.


many thanks for your request. I would recommend to start with a Debian minimal installation directly on your PC and perform a transformation into DietPi later on. Just have a look into the following link:


If needed a step by step guide :wink:


Thank you for your response, I’m glad there’s another way. I will do that procedure right now and I will be updating this thread once I have this thing running.

I have been working on Dietpi installation for my repurposed PC, but unfortunately I always end up with a failed installation. Here’s what happened.

I managed to install Debian but ended up installing Raspbian instead. Installation worked perfectly, setup a static IP, turned on the ssh & restarted. Now I did the ssh procedure as SU and pasted the commands to convert Raspbian to Dietpi. It works and I can see it on the client screen as the ssh commands were removing services on the Raspbian and even removed the GUI. It went well until, on the SSH screen on another PC it came up with an error. I managed to operate into the Dietpi-config through SSH and found out that the Ethernet Driver is missing and can no longer carry on the update to complete the installation.

I tested the UEFI, on a UEFI capable PC and it works as its using Clonezilla and there is a working image inside the package.

If only there was a similar package for the BIOS version, this procedure would be easier for novice user like me.

That’s confusing. You managed to get connected via SSH?? But how should that be possible with missing network card driver?


I agree with that, If only I could replicate what I managed to get, but unfortunately it only happened once. Now every time I redo the installation it would still do the same thing and I can no longer reach the dietpi-config. Funny thing is it happened only once, accessing the dietpi-config only to find out IPV4 and 6 are undetected something like that.

For now I would leave it just that. I can still have my RPi run the Dietpi with FTP on it to serve as our Fileserver with no problem.

I will wait for future updates of Dietpi for BIOS, and maybe they will release similar installation as the UEFI with clonezilla on it.

Thanks for your support Joulinar, I really appreciate your support for the community.

pls keep in mind, it might not be possible to include all kind of network driver for all kind of network cards. :wink:

If you have another ethernet laying around of a different model/make/chipset try that