Unable to access Raspberry Pi homepage by domain on iPhone

Creating a bug report/issue

Hi, I can access on my 2 Windows 10 PC my different Raspberry Pi servers (Portainer, Webmin, Bitwarden…) by IP address ( or by Domain (http://raspberrypi:5331) but on my iPhone it no longer works by domaine (only by IP). Same thing for Bitwarden app on my iPhone (only works with the IP). Any suggestions?

Required Information

  • DietPi version | 8.14.2
  • Distro version | buster
  • Kernel version | 5.10.103-v7+
  • SBC model | RPi 3 Model B (armv7l)
  • Power supply used | 5V 1A
  • SD card used SanDisk ultra

Extra details

  • I run regulary updates of DietPi OS and Pihole
  • I changed my router recently

Looks like a DNS issue on your mobile phone. Check that your phone is using correct DNS.

Hi, I have an iPhone 13 with iOS 16. I didn’t specify any DNS. It’s using “automatic settings”; basically the iPhone shows the DNS set in the router (Theses DNS are et by the ISP).

Ist this s real domain or just a hostname?

maybe the new router needs to be redirect to PiHole instead of ISP?

Hi, it’s just a hostname.

In Windows 10
ping raspberrypi
Pinging RaspberryPi.local [] with 32 bytes of data:
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64

Just by curiosity why it inlude .local? I tought that was no longer used in linux! Does it means something is not set right?

I forget to mention, with DietPi installer, I installed Pi-hole but also Unbound recursive DNS server (both were installed a long time ago).

It might work with 2 downsides, if I’m not home that DNS will not work on my iPhone and if I’m home and my phone decides to do Wifi calling it might cause long distance charges because my cellphone provider might think so (In Pi-hole I’m using google DNS but I live in Montreal). If it’s the only way either I disable Wifi calling or reconfigure bookmarks in Heimdall and some others places to point to 192.168…

iPhone is brand new (a few months), router has been factory reset. I could try to reinstall DietPi from scratch but if there is anything else I can try before that it would be nice! :slight_smile:

In Windows 10, I can ping raspberrypi domain and IP address without specifiy any custom DNS in TCP/IP!

On the iPhone it worked a few minutes (browsing by domain) after manually adding as the DNS and then stop working!

It could be an iOS / Apple restriction, something with Pi-Hole, Ubound or DietPi that I have to reinstall from scratch or like you said I could be “forced” to put Rpi DNS on the router but I just don’t understand why 2 Windows PC works and not the iPhone!

Since it’s not a domain no DNS is involved, only DHCP.
My guess is also some apple restrictions, but not sure.

for what reason you have installed PiHole if you are not making use of it?

Anyway, our DietPi by default are not distributing / broadcasting any host names. Sometimes on a router you could see the .local settings. Have a look in your router device how DHCP is configured. Usually, you could specify local hostnames there as well.

I forgot to mention on detail. Before the test, (Rpi DNS) where specified manually in Windows 10. I removed DNS in Windows 10 to see if I can access raspberrypi server by domain (with default Windows 10 DNS) and it works.

I put back the DNS back in Windows 10 ( so Pi-Hole works (for the computer but not the phone which is volontary).

The reason why I put Pi-Hole DNS in Windows 10 instead of the router is to make sure when I do Wifi calling I’m not charged (Pi-hole is using Google DNS).

If I wasn’t using Wifi calling then I would use Rpi DNS in my router instead of manually adding them for my 2 computers!

The only thing that I don’t understand is why Windows 10 find raspberrypi domain but not iPhone!

I believe a restriction with Apple products, at least with iOS 16.

If there is no other solutions, I’ll try to reinstall DietPi from scratch with the latest Debian image and possibly without Unbound (not sure if it makes a big difference with my Rpi 3 with 1 Gb of RAM!).

I don’t have a lot of options for my router, not sure that I can specify a local hostname

If I do http://raspberrypi.local/ it works?

I doubt that a reinstall of DietPi will change anything. As well the resource of your RPi doesn’t matter.

Still I guess you have a misunderstanding how DNS resolution is working. There should be no differences in your location spotting by your ISP if you use PiHole. Usually, your location is determined by your IP address and not by the DNS server used.

Next to this, you should not set local DNS server manually. Simply adjust your DHCP server to set PiHole as local DNS. This way, your mobile phone will get PiHole once at home. And if you are out, you will receive settings from your mobile provider.

I agree with you at 100%; It would be logical but they mention on their web site : “You may get charged for long distance and/or international messages if your VPN, DNS or internet provider is set to a country outside Canada.” My Pi-Hole is set to Google DNS which is located in United States! The charges apply only if I do Wifi Calling with my cell phone when I’m home! I won’t think to turn off Wifi calling everything that I would be home.

The other dicovery that I made : http://raspberrypi.local/ works on the iPhone but I have to reconfigure all Heimdall servers which is a waste of time.

So either I take a chance of not being charged or still look for a solution, if I can find one!

There are also two “Edge Points of Presence” for Google DNS in Canada: Toronto and Montreal. But if you are located more to the West, I guess your requests would land in Seattle or The Dalles, indeed.

However, I think it is ruled out that you get charged for WiFi calls if you use Google DNS, Cloudflare or any other public DNS provider which does not manipulate globale DNS resolving. The DNS requests themselves are not charged and as long as the hostname of your recipient is resolved to the same IP address, the exact same call is done and your ISP is not able to know which DNS server was used.

Another solution would be to switch Pi-hole to your ISP’s DNS. If it has a fast/close data center, it could be even better/faster than Google DNS.

yes that would be my recommendation as well in this case.

My router is : TP-Link Archer AX50 (AX3000 Dual Band Gigabit Wi-Fi 6 Router)

When I try to save Rpi DNS ( it fails. Errors message :

DNS server IP address and LAN IP address cannot be in the same subnet.
Please enter another one.

For DHCP Server I also have DNS but it does nothing! Not sure of of the difference between the DNS of theses 2 screenshots!

In all cases it still doesn’t work on the iPhone. Not sure of what I can do next. Also, I don’t have the option to make Pi-Hole works the way you suggests me or I miss something!

ok first picture needs to be set to your ISP DNS it seems.

On the 2nd screen you would need to add primary DNS only. Pls remove the secondary DNS option. To force your DHCP client to use the new DNS server settings, you would need to restart or reconnect them. This will force your device to get a new IP/DNS config. Once done we could work on your issue with local DNS resolution. First ensure you see the clients resolving DNS with Pihole.

Hi, settings are saved on my router! I confirm that I can browse local domain on all computers (http://raspberrypi:3689 as an exemple).

On my iPhone 13, it still failed except Bitwarden because it’s using HTTPS (https://raspberrypi:8001/) but any other local servers like Pi-Hole failed (http://raspberrypi/admin/).

All my devices take advantage of Pi-Hole (I see my devices IP address listed in Pi-Hole) and I confirm that all devices are set to Automatic DNS (Before was set manually to on PC and iPhone).