Unable to access airsonic behind reverse proxy


I had installed DietPi on a x86 computer for testing before installing on my Raspberry Pi 4 4GB
I was able to access services behind the reverse proxy without issue and after testing I decided to put it on my Pi

After installing I changed the user data directory to save to external HDD
Then installed Airsonic
When I try to access Airsonic remotely it shows a 503 error
I checked the reverse proxy logs and it states

HTTPS: attempt to connect to ( failed

Seems strange that it worked on the x86 but not the Pi

Any ideas? I am running off little sleep so it is probably something really simple!!

Also, because it seems the connection fails I am finding it hard to find logs on the DietPi install. Please let me know if anyone can think of anything to do with this

Kind regards,


not sure how you setup your revers proxy but it seems it’s trying to connect to on port 443
Best to my knowledge airsonic is using port 8080 by default.
Did you tried to access airsonic locally without proxy to see if it is working in general?

Sorry, wrong log line

HTTPS: attempt to connect to ( failed

I am installing Nextcloud too in order to test that as well

Yes, it does work locally

OK, I think it may be a config error within the reverse proxy
I will check and update when I confirm

Are you sure airsonic is reachable via HTTPS??

HTTPS: attempt to connect to ( failed

Now, I have gotten Airsonic working by trying port 8080 and http rather than https. Allowing my reverse proxy to do the SSL heavy lifting

I got Nextcloud installed and setup a new entry in my reverse proxy. The system once again failed 443 but when I changed it to http:// it seems to work

Is 443 blocked in DietPi?

No, but you did not activate HTTPS on your NextCloud server I guess.

Usually SSL handling is done by the proxy while the systems internal reachable on http

Ok then, my bad!! I will set all services as http in the proxy in future

By the way, loving this environment
You’ve all done amazing work

Thank you

one question. What kind of revers proxy you are using?


I think it might be an issue with performance as it seems fine when doing nothing stressful but the minute I start doing a scan or something in Airsonic it throws up this error
I will try and get a faster SD card this week and continue testing

I was thinking if you would like to create a small how-to on using Apache as reverse proxy. I guess it’s still missing and probably other users could benefit on your knowledge in that topic :slight_smile: