UEFI DietPi on Intel Atom miniPC - efi esrt errors


Every time I boot I get:

[0.000000] efi: requested map no found
[0.000000] esrt: ESRT header is not in the memory map.
[1.781496] i8042: Can't read CTR while initializing i8042

It sometimes get stuck there, other times it boots correctly.

I created the UEFI DietPi image using the clonezilla bundled version. I booted with it (pressing F7) on a USB 2.0 port, and I put a 64 GB USB Stick in the other USB 2.0 port. Then, I told Clonezilla to install it on sda1. When done, I went into the UEFI (pressing ESC) and I chose “debian” on the first place. I don’t install DietPi on the eMMC 32 GB internal drive (not yet).

I have tried to do the same with a USB 3.0 1 TB HDD connected to the 3.0 USB port and installing DietPi there. The results are even worse, because DietPi sometimes gets freezed while it’s running.

I suppose it must be related to that messages, am I right?

Some ideas?
Thank you,

Nobody answered. It finally booted with an USB drive but I cannot boot from an external HDD correctly.

Trouble is related with efi boot, I’ll try on github and hope somebody’ll answer.

Sorry for the late reply. Too busy with other stuff to catch up with all GitHub and forum issues the last weeks. Did you open a GitHub issue already? Can’t find it there? And jep, usually you will get attention there faster by devs.

Generally: https://github.com/Fourdee/DietPi/issues/1171
I am not deep in the UEFI topic, but at least it was not possible to switch the install target location, since it was hard coded into the Clonezilla image. There were some efforts to allow changing the location, but I am not sure how far this has gone.

MichaIng, thank you.

I can explain what I did.
1- I created the UEFI USB Installer in a USB drive.
2- I installed it in another USB drive.
3- I booted it. The trouble: if I disconnect and connect again the USB drive or I boot from Windows, the UEFI boot entry disappears and cannot be recovered, unless I reinstall DietPi again. I tried using efibootmgr and parted magic, nothing worked.
4- The solution: I created a rEFInd USB drive. Pressed ESC to tell to the UEFI to boot from there. rEFInd always boots and I can decide DietPi or Windows.
5- Improvement: I wanted to have DietPi on an external 1 TB HDD, not in a 32 GB USB drive, so I used Clonezilla to clone from the USB drive to the HDD. HDD can be connected to the USB 3 port and it boots, using rEFInd as the “portal” to get into it.
6- More issues: After 24-38 hours Dietpi “died” (HDD disconnection) and I had to reboot. I replaced the USB 3 HDD enclosure, and now I’m using a USB3-SATA3 adapter, and now I don’t have more HDD disconnections.

So, the config is: one USB drive booting rEFInd, one SATA3 HDD with DietPi installed (I repartitioned it using GPARTED, to be able to use all the space of the disk).
Speed is very good, 100 MB/S, and it can be improved if you upgrade the HDD to an SSD.

That’s all, now it’s been running for 29 days without any interruptions.

Thanks for sharing your solution!

Yeah rEFInd seems to work, users discussing the same here: https://github.com/Fourdee/DietPi/issues/1171#issuecomment-447573091

There seem to be an alternative Clonezilla which works as well: https://github.com/Fourdee/DietPi/issues/1171#issuecomment-437114374

However I have no experience with this. I hope Fourdee and the guys from the GitHub topic manage to create new working images, based in rEFInd or whichever works.