Trying to run DietPi on a VPS

Hi all,

I would like to run DietPi on a VPS Server at IONOS (former 1&1, a Hoster in Germany).

As they offer installing from own images (Supported file types: .vdi, .qcow, .qcow2, .vhd, .vhdx and .vmdk), I first tried installing the pre-built DietPi image for VMware as it is a vmdk-File but it did not work - same error as shown below.

Then I tried converting the ready-to-run image of Debian 10 offered by IONOS themselves to transform this into DietPi with the thing ( | Automate · Issue #1285 · MichaIng/DietPi · GitHub).

The installation itself went through without any errors, but after reboot it is stuck with the same error as when installing the VMDK-File.
Please see the attached screenshot from the virtual KVM-Console.

Has anyone any idea how to solve this?

Thanks and best regards

any idea, someone?

One of the DEV’s should pop in soon

I have never run it in a virtual machine so I don’t know how it would work…did you go thru the virtual machine and ensure all the options are set correctly?

unfortunately, there is not much to set. Or what exactly do you mean?

probably something to discuss with IONOS. Probably there are some condition needed to start a VM on their platform.

Did you solve your Problem with ionos?

I have the same Problem.


This is the device mounts on a freshly installed Debian 10 Ionos VPS:

root@localhost:~# df -h
Filesystem             Size  Used Avail Use% Mounted on
udev                   214M     0  214M   0% /dev
tmpfs                   46M  5.2M   41M  12% /run
/dev/mapper/vg00-lv01  7.5G  1.3G  5.9G  18% /
tmpfs                  230M     0  230M   0% /dev/shm
tmpfs                  5.0M     0  5.0M   0% /run/lock
tmpfs                  230M     0  230M   0% /sys/fs/cgroup
/dev/sda1              464M   84M  352M  20% /boot
tmpfs                   46M     0   46M   0% /run/user/0

So it seems that the Script renames the “dev/mapper/vg00-lv01” or changes the mountpoint to /?!

I think this could be solved in the Debian->DietPi Conversion Script somehow?!
Would be really nice if we could get dietpi working on ionos VPS.

Thanks in advance for any help!

Hi Guys,

MichaIng was able to provide the needed steps to be able to run at IONOS. Basically it started at the the following on GitHub