Trouble Installing MATE Desktop (File doesn't exist)

I am trying to install the MATE desktop, but partway through the installation I get the following error:

- Command: Connection test:
- Exit code: 8
- DietPi version: v6.28.0 (MichaIng/master) | HW_MODEL: 1 | HW_ARCH:1 | DISTRO:5
- Image creator: DietPi Core Team
- Pre-image: Raspbian Lite

Below is the log file content:

Spider mode enabled. Check if remote file exists.
--2022-03-24 00:05:47--
Resolving (,,
Connecting to
(||:443... connected.
HTTP request sent, awaiting response... 404 Not Found
Remote file does not exist -- broken link!!!

I understand that this is due to a file renaming, and I followed the directions in a previous forum post, using

apt-get update
apt-get upgrade

and I even made sure there were no additional files being installed/upgraded after running these commands a second time. But, I still got the same error. The other forum post also said something about changing the command to edit the file name, but the only options I see are “Retry, DietPi-Config and Send Report”. So, is there anything else I can fix?
The DietPi I’m currently using was installed quite a while ago, but everything is up-to-date now, so I’m not sure why it is consistently throwing this error.

You dietpi version 6.28 is very old one. Pls update to latest version 8.2 first.

I’ve tried updating using

apt-get update
apt-get upgrade

but clearly that hasn’t worked, even when I ran it twice it told me there was 0 new installs and 0 new updates.
Is there an upgrade command I’ve missed?

There should be a red message while login to Dietpi indicating to execute dietpi-update

Oh I see, I unplugged and replugged the pi, but for some reason it’s only asking me to update from 6.28.0 to 6.35.0 though?
Also I’m not sure why (maybe because the installation got stopped halfway?) but my keyboard is no longer connected to the pi, even though it had been working perfectly before…
Should I consider just clearing the SD card and redownloading dietpi?

Yes 6.35 is ok. This is a technical limitation and 6.35 is a transfer release to DietPi 7. The update script will do the update to the last version available.

You have still SSH access from where you could start the update?

Unfortunately I do not…I realized that there were also files from a previous installation so I decided to completely wipe the disk and then download and etch the ARMv8 64-bit image. However, after doing that I’ve seemed to encounter a whole new set of problems. When I put the SD card into the pi, and connect to the monitor, it seems to be stuck on a grey screen. The monitors detects the pi’s signal, and the pi’s red light is on as well. However, the green light is flashing 7 times in a row and then pausing. I believe this is because of Kernel image not found, but when I view the files on the SD card, there is a disc image file called ‘Kernel8’. Does it strictly have to be “kernel.img” or am I missing some other aspect of installation.

For reference, I am currently using a raspberry pi 3 model B, connected to monitor via HDMI, as well as computer mouse, keyboard, and Ethernet. Below is what I’m currently seeing on the SD card.

usually flashing the image should work ootb. There is no need for any further configuration. Maybe you have a spare SD card you could try.