Hi, in the past few days transmission-remote gives me the “Permission denied (/path/to/download/folder/)” error for torrents added by medusa or torrents added by me manually.

At first i thought it’d be a permission related issue but the download folder is drwxrwxrwx as it’s always been, I then tried creating a test folder like this:

drwxrwxrwx 3 debian-transmission debian-transmission 4.0K Jan 22 13:25 test

But still no luck, same permission denied error.
I then run fsck, fixed few errors, but still same error. Other services running in this dietpi install are still able to write.

Nothing has changed in this install besides, before noticing these errors, installingf webtrees which, to my knowledge, it should’t have anything to do with transmission.

Anybody has any idea?
Shall I post more code?

Thanks in advance

Not sure about transmission-remote, but transmission itself runs as user transmission-daemon.
If your download folder is inside /mnt/dietpi_userdata/, please try to add the user, that runs transmission-remote, is in the dietpi group, e.g. usermod -a -G dietpi debian-transmission
EDIT: Ah sorry, was mistaken, the service and package is called transmission-daemon, but the user debian-transmission :roll_eyes:

Okay but now I see you tried with a 777 test dir, so regardless of user this should work :thinking:.

What you should check:

  • To access a directory, the user requires at least execution permissions to all parent directories (which allows checking included file/dir names).

Besides them not sure, depends also how transmission-remote is initiated. Systemd units e.g. can limit access to certain system and user directories, regardless of run user.

EDIT: Is it that you use, or ?
So those are client’s that access the transmission-daemon (server).

Does everything work fine, if you access Transmission via it’s web interface, instead of using transmission-remote?