Transmission error

I keep getting the following when trying to reinstall transmission:


pls do following and repeat the installation afterwards

groupadd -r debian-transmission
usermod -aG debian-transmission debian-transmission

now have this

did you rerun dietpi-software ?


can you share following

cat /etc/transmission-daemon/settings.json | grep whitelist

if possible copy the output from SSH terminal and avoid creating screen prints

root@dietpi:~# cat /etc/transmission-daemon/settings.json | grep whitelist
    "rpc-whitelist-enabled": false,
    "rpc-whitelist": "",

strange, whitelist-enabled is set to false and shouldn’t have any effect. Did you tried to reboot already?

Yes no difference

Any ideas?

You could try adding your local client IP to rpc-whitelist. For doing this, you would need to stop Transmission first, perform the change and start Transmission afterwards. It’s important to have Transmission stopped while doing the change. But I would wonder if this has any effect as whitelist-enabled is not active.

There seem to be some lines missing. Please post the whole file, redacting the password.
cat /etc/transmission-daemon/settings.json

Here you go:

"umask": 7,
    "message-level": 0,
    "rpc-whitelist-enabled": false,
    "trash-original-torrent-files": true,
    "ratio-limit-enabled": true,
    "ratio-limit": 1.1,
    "idle-seeding-limit-enabled": true,
    "idle-seeding-limit": 1,
    "upload-slots-per-torrent": 5,
    "peer-limit-global": 40,
    "download-queue-size": 3,
    "cache-size-mb": 788,
    "blocklist-enabled": 0, 
    "download-dir": "/mnt/dietpi_userdata/downloads",
    "download-limit": 100, 
    "download-limit-enabled": 0, 
    "encryption": 2,
    "max-peers-global": 200, 
    "peer-port": 51413, 
    "pex-enabled": 1, 
    "port-forwarding-enabled": true,
    "rpc-authentication-required": 1, 
    "rpc-port": 9091, 
    "rpc-username": "root",
    "rpc-whitelist": "", 
    "upload-limit": 100, 
    "upload-limit-enabled": 0

You have some weird values here:
rpc-authentication-required is boolean, not integer. Same for pex-enabled.
Maybe the default configuration file is overridden by environmental variables such as TRANSMISSION_HOME.
Also rpc-host-whitelist-enabled is missing and by default is true.
Maybe the quickest way to fix it is to set the IPs in rpc-host-whitelist and restart the service.

How would I do that?, I’m still quite new to Linux

or remove transmission and perform a new installation to get correct config file. Might be fastest.