Transmission crashes

Does anyone else have trouble with transmission crashing? For me, it works fine for a while, sometimes a few minutes, sometimes for days, but at some point it crashes.

I’ve tried lowering the “max peers per torrent” and the “max peers overall” but it doesn’t seem to improve. I have my raspberry pi connected through ethernet downloading to a network drive. I think I’ve tried downloading to a local drive instead and still crashed (a while ago). I’ve also tried deleting and reinstalling transmission.

Anyway, it’s not critical but it’s a little bit annoying. Any clues will be appreciated. Thanks!

DietPi | Tue 05/03/19 - 22:20
────────────────────────────────────────────────
v6.21.1 | RPi 3 Model B (armv7l)

DonLiborio
Many thanks for your report.

Please check your RAM usage when it’s running a while:
free -m

After a crash occurred please check:
dmesg | tail
journalctl -u transmission-daemon

Just before reading your reply I realized I had increased the “cache-size-mb” to 128 MB, to avoid excesive activity to the network drive. But I read doing that increases the RAM usage a lot. So, I now lowered it to 32 MB. I’ll let you know how it goes. If it’s fixed, it was RAM related as you suggested.

Thanks for your reply, MichaIng!

All the best.

DonLiborio
Yeah give it a try.

I mean 128M vs 32M in a 1G board (+ swapfile) should not break things. But of course it depends about other software you might run on your RPi.

The suggested commands above should still give a hint if it crashes.

Yeah, I thought increasing it to 128 MB shouldn’t be too bad. But then I read this:

https://forum.synology.com/enu/viewtopic.php?t=34017

where someone complains that raising the cache size parameter to 256 MB made the RAM usage balloon to 650-680 MB with just 4 torrents. I don’t know how reliable this report is but I thought it was worth giving a try to lowering the cache.

So far, so good with the 32 MB cache. No crashes.

Ah okay this indeed sounds like the cache is meant per-torrent. Reasonable that 2M is default then and perhaps we need to reduce 32M default based on available RAM :thinking:.

Still no crashes with 32MB (remember I had 128MB). Maybe it’s OK with 32.

Thanks for looking into this. DietPi is great for what I use my Pi.