Transmission CPU overload & ownership change


When Transmission is downloading it consumes so much of my SBC’s resources that accessing the Transmission web-gui or controlling Transmisison with a remote app becomes near impossible. Access to DietPi via SSH is also severely impaired and other apps grind to a halt.

I’ve tried other torrent apps on DietPi and they don’t have the same issue. However, the simplicity of Transmission is by far my preferred choice.

I tried to follow the suggestion elsewhere in this forum that it could be remedied by changing the ownership of the download folder to debian-transmission:dietpi. Unfortunately, when I try to make the change I find the operation is not permitted.

My download folder is at /mnt/torrents/transmission. While in /mnt/torrents I tried to change the ownership with:

  1. chown -R debian-transmission:dietpi transmission

  2. chown debian-transmission:dietpi transmission

How do I change the ownership? Sorry if this basic knowledge is a bit of a bother.

not sure if changing the ownership will change anything on resource consumption.

Anyway, to have a look your can do following

lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
ls -la /mnt/torrents/

I got the suggestion from this post:

Apparently, your solution to another issue also solves this problem with Transmission.

As requested below.

sda 461.3G 0 disk
└─sda1 exfat torrents 461.3G 0 part /mnt/torrents eea31415-8459-46d6-b70b-4789a4f9d925 BE1F-09DF
sdb 116.1G 0 disk
└─sdb1 ext4 116.1G 0 part /mnt/cops bcd52a68-87c1-4b81-929f-7345b26281ef 561325f0-6181-41ad-a79c-1acef5a4c729
mmcblk1 7.5G 0 disk
└─mmcblk1p1 ext4 7.5G 0 part / fbb3d018-01 92b2ac71-76f3-4e7f-a35f-1fbe34221b88
total 260
drwxrwxr-x 3 root dietpi 131072 Jan 11 12:05 .
drwxr-xr-x 8 root root 4096 Jan 8 11:58 …
drwxrwxr-x 2 root dietpi 131072 Jan 11 12:00 transmission

Your disk is using a fat file system format not supporting any Linux user permissions. Therefore you are not able to change user and group.

Oh balls!

I tried to format the flash stick to ext4 with DietPi but it wouldn’t work. Neither would the formatting work with my desktop & gparted.

what is the error if you use drive manager to format die disk into ext4?

Sorry I can’t remember exactly, but it was something like Format Error: 64-bit filesystem is not enabled.

However, I’ve managed to format the flash drive to Btrfs and Transmission is working fine now. With no excessive resource hogging. I don’t know if Btrfs is a good long-term choice but for the present it seems to be ticking along OK.

Better than a fat file system :wink: