Transmission : Can't remote access when a torrent is downloading

Hi,

I use Transmission on my Dietpi install but I’ve got an issue : When a torrent is downloading, I have big difficulties to access Transmission with a remote (web version or softwares).

It just can’t connect (it only works 10% of the time). And at the moment the torrent finished downloading, everything comes back at normal. I can connect without issues.

I searched a lot about this, can’t find anything on the subject because it’s obviously a vague search.
Does someone here knows about this problem ? Any idea on how to fix it ?

Thanks in advance for your help, any idea is welcome. Have a good day

Which device is that?
Can you do other things when a torrent is downloading?
SSH works fine for example? If yes, can you check htop and see how is CPU and memory utilized?

It’s a raspberry pi 4 4gb. I can do other things, but with a lot of difficulty. I can SSH and other apps works, but it can’t connect half of the time. It’s like it cuts the full internet connection. I cannot access the remote transmission server at all.

I already tried fully wiping and reinstallign everything on the pi, didn’t work. It’s still the same. I don’t know what to do. I tried looking into my router settings but everything is normal.

how does CPU and memory looks like while your system is freezing? We had a similar report on Github where large file write leads to a freeze on the system. Basically transmission was using entire memory and did not released it anymore.

https://github.com/MichaIng/DietPi/issues/3330

Issue was with transmission version 2.92, and it was fixed in 2.94. Not sure which version you are running.

Hi !

New update on the issue :

I had another issue with transmission, here is the post about it :
https://dietpi.com/forum/t/transmission-error-access-denied/4256/1

Joulinar helped to solve it. I don’t know why, but it also fixed this issue !

Here is the solution :

I made the 1st option, and it solved that too !
Thanks again Joulinar. You’re the best.

Have a great day everyone !

strange that this seems to fix it. But good that it is working now.