TinkerBoard not booting 6.18

As the topic says, there is no disk activity when inserting Diet Pi SD card into Tinkerboard (non-S model). No logo on screen, like the board is dead.

Things tried:

Download image again
Extract .img file again
Fresh write on different SD card
Fresh write using Win32DiskImager and Rufus instead of Etcher
Boot Tinker using other software on same SD card (worked)

I was hoping that since my last unsuccessful attempt at making something useful out of the TB, the software side had evolved a bit over the last year. But I can’t do anything if it doesn’t boot.

Thanks for your report.

Strange that it does not boot from the beginning although no hardware issue if Tinker OS otherwise runs… Not sure if S/non-S makes a difference here. Will forward this issue to GitHub, let’s see if Fourdee has some idea: https://github.com/Fourdee/DietPi/issues/2533

Please read Fourdees comment on the GitHub link above, as on his testing on both TB models the image bootet fine. If you are sure that the power supply is fine (serving stable voltage), indeed it is an idea to test overwriting the whole SDcard cleanly.

As you tried already with two different SDcards: Was one of them new, or are they older? They die quite fast, depending on quality, gaining bad sectors where every data written to will be corrupted. Rufus has an option to test for bad sectors. But important to know that this means the whole SDcard will be written to (to read back and compare), so decreasing life time quite a bid.

Yeah so first I would assure that your PSU has good quality. Perhaps test with a different one (if available) or e.g. use a micro USB to USB adapter and attach to a laptops/desktops USB3.0 port.

I’m running into the same problem. I’ve even gone out and purchased a new drive. As soon as I try a different OS like Armbian for instance it boots.

Thanks for the replies, I rewrote Volumio to the SDCard and it boots fine so the card is okay.

I am going to assume it is another foible and try and get Linaro ugh to do what I need. Diet Pi is lighter and might suit me more, but I had quite a few issues last time around too, and Armbian simply wouldn’t expand the filesystem so I could not longer update as I kept running out of disk space. So I put Linux and the Tinkerboard on hold for a year and a half.

However summer is here and I need a small, low-power fileserver so hopefully the Asus default software will work out for me.

There is really no output on screen and no disk activity shown when you try to boot? I am not sure about Tinkerboard uEnv or similar configuration possibilities. After flashing the SDcard, can you find any boot configuration file on it? Perhaps there is a way to enable verbose boot output (instead of a splash/logo) and perhaps even some other settings that might affect the boot process.

I’m having the same issue today.
Pulled the Dietpi image apart, and it dumps the root partition, not the normal set of 0.fat, 1.img etc for partitions.

It’s based on ARMbian where this partitioning is usual: https://www.armbian.com/tinkerboard/

Sadly the image/kernel version we used is not available there anymore to allow an exact comparison. But the Stretch kernel 4.19 version looks exactly the same. Could you try this out one out?

I can try out anything. I was looking for a depreciated version to see if that worked and do a compare of the file structures.
I’m not familiar with Armbian, I generally always use a Debian version.

ARMbian is based on Debian, so this is very similar besides some additions similar to DietPi.

We generally don’t support or offer deprecated DietPi versions but instead fix the current one if required. Since for most users the TB image works fine we have to investigate what is different in your cases where it doesn’t work :thinking:.

I think I have a dodgy board, so ignore me now. It was old, and I was planning on buying an sbc with more gumption soon.
So that will have to be put to the top of the list.
Sorry to have wasted time.

No worries, if you are as well not able to run another Debian-based OS currently, then I agree :wink:.