The new Raspberry Pi 4

let me know if you are able to use my Experimental img with your ssd… I had to re-install the system on mine, and i run into a kernel panic when try to boot through usb… so i had to make a fresh debian install again (but i scripted that, so if you have issue, i can easily give you the script, have gparted the usb target, then copy past the script into a root terminal, press enter maybe 8 times, type 2 the wished debian user password, adjust the fstab and reboot ^^ ).
ho, and my script include the dropbear install, so you not need to care about receiving the micro hdmi cable to use it :wink:

lpw
I just created a PR to allow ownCloud install with PHP7.3 due to recent release: https://github.com/MichaIng/DietPi/pull/3169
After updating to DietPi v6.26, please try:

wget https://raw.githubusercontent.com/MichaIng/DietPi/owncloud/dietpi/dietpi-software -O /DietPi/dietpi/dietpi-software

This should allow you to install ownCloud on RPi1/Zero and Buster-based systems via dietpi-software.

I will keep this branch active until v6.27 release, since it does not contain any other changes yet, hence is safe to use on v6.26.

@MichaIng,

I did a clean install ( official dietpi ) and transfered the Userdate to SSD. I got lots of errors at reboot (see attachements) It seems that the Pi4 now boots into save mode.
Photos.zip (4.53 MB)

you went with the official dietpi img or my experimental (debian) one ?

I putted a first commented version of the script I made to largely automate creation of a debian arm64 for rpi on a external drive (for now it’s targeting sda2, so be sure to have only one external drive connected), if you want to use it, it’s a simple copy paste into a terminal, few “enter” hits, one password to choose and one " ./buildcontinue.sh " to enter

https://github.com/thaneb/Debian-SystemBuilderRPI/blob/master/autobuild.sh

after the reboot, you can install DietPi with the

bash -c "$(curl -sSL https://raw.githubusercontent.com/MichaIng/DietPi/master/PREP_SYSTEM_FOR_DIETPI.sh)"

I wanted to improve the script with arguments and drives/partitions detection and choices options, but my family doesn’t help me to have enough free time to improve my bash knowledge to go as fast as I would like ^^

@ ThAnEb, I will have to redownload the experimental dietpi-img but it’s hard! (link/site doesn’t work always, even if i allow flash/ads/cookies/everything)

ps: downloaded with edge this time. Don’t know why i have to use a different browser every time (?)
ps2: Moving userdata to ssd worked (reboot went fine) using dietpi-menu.
ps3: i am installing smb/nfs/syncthing and homeassistant now…

Sorry for the issue you encountering with 1fichier, i never had any issue with them for dl (from France, Switzerland or Thailand), but i will look for an alternative file holster tomorrow for make it more smooth. A good alternative (that can be also a good way to learn more about debian distrib) , may be to look the script i putted on github and other maybe adapt it for specific needs or installation, at the end you dl almost the same amount of data, but you start to know how to make your own debian kitchen ^^

EDIT : I just change the usb adapter used for my “rootfs” ssd, and it was not booting… thanks to its led activity status, I saw that it was late to switch on, so I moved the drive to a self powered usb 3.0 hub, and of course, it boots without any issue.
So, have to know that depending on the usb adapter used, a self powered hub may be required to allow the boot.

Hey guys, just a suggestion:
Probably is is beneficial to discuss the RPi x64 topic in a separate thread here or GitHub issue? I really like to collect experiences, especially since an x64 kernel is now officially integrated into the new RPi Buster firmware packages. Any testing and error collection should be helpful to report back to RPi developers, and by this help to have a soon Raspbian x64 release with stabilised firmware.

In this thread, where it was about RPi4 support with regular x32 Raspbian, it is probably confusing for others, reading it?

Ok, I got the point, sorry, i will look where it would be the most relevant to speak about that, sorry for the mess here :confused:

Sorry MichaIng.

Will stick with pure DietPi for now…

As said, I don’t want to break any testing with this, as IMO x64 should become default for SBCs quickly as well, and its somehow a mess that already RPi2 PBC 1.2 actually has an ARMv8 (x64) capable CPU but Raspbian is compiled for ARMv6 (armv6hf).

So playing with the new x64 kernel totally makes sense, but a separate thread allows better tracking, not disturbed by other posts that are related to RPi4 in general (as of topic).

Just to mention:
On DietPi v6.26.3, booting from ssd (rootfs) works if the ssd (on a usb to sata cable) is on a powered-usb-hub.
Syncthing can be installed but no lamp-stack is installed automatic.

Great to hear. Jep external drivers on SBCs should always be powered externally. So not rely on the max 1.2 A shared over all USB ports.

Syncthing does not require any dedicated webserver or database. It has it’s own little integrated webserver.

I installed:

syncthing *
homeassistant *
smb (didn’t work in the beginning, i modded the filerights and now i can access the share on a win-box)

  • don’t work.

Dietpi-services shows that syncthing and homeassistant failed to start. (restart doesn’t help)

ps: could this be because rootfs and dietpi-userdata are on sda1? (ssd)

pakikje
To fix Syncthing, please run:

chown -R dietpi:dietpi /mnt/dietpi_userdata/syncthing*
systemctl restart syncthing

Ref: https://github.com/MichaIng/DietPi/issues/3180

For SMB, if it worked at the beginning, review your filter changes to check which one broke access? :wink:

For Homeassistant, I can do some test. However error messages or logs you encountered would be helpful.
EDIT: Same issue, please run:

chown -R homeassistant:homeassistant /mnt/dietpi_userdata/homeassistant
systemctl restart home-assistant

Location of userdata should not play a role unless the external drives file system supports UNIX permissions. But that is checked when transferring userdata and rootfs.

fix worked! Thnx ( i started from scratch, smb works too…)

Is it possible to overclock the Pi 4 to 2.147 Ghz running the latest version of DietPi?

My Pi 4 doesn’t even boot when I select the High ARM in dietpi-config so maybe I lost the silicon lottery as-is but I’m just curious if we can go higher.

Thanks!

Try to increase the overvoltage manually in /DietPi/config.txt (or config.txt from boot partition when plugging the failing SDcard into external system). Since it runs mostly stable with overvoltage 4, we set it to 5 already to be failsafe but probably there are some boards where even 6 is required.

Higher ARM clocks are possible like on Raspbian but out presets only contain values that run with usual cooling systems on acceptable temperatures.

I installed the 64-bit Dietpi version,
Image : DietPi Core Team (pre-image: Raspberry Pi OS (64-bit))


but I get ’ No supported WiFi hardware was found. ’

How do I enable the WLAN chip ?

francisp
I see you posted same question on GitHub. https://github.com/MichaIng/DietPi/issues/3570#issuecomment-715747607
Let’s stick to one platform pls. It doesn’t make sense to raise same question multiple times. :wink:

According DietPi statistics Rpi4 is the most used SBC now. going to mark this as solved.