The new Raspberry Pi 4

Great to hear. Jep external drivers on SBCs should always be powered externally. So not rely on the max 1.2 A shared over all USB ports.

Syncthing does not require any dedicated webserver or database. It has it’s own little integrated webserver.

I installed:

syncthing *
homeassistant *
smb (didn’t work in the beginning, i modded the filerights and now i can access the share on a win-box)

  • don’t work.

Dietpi-services shows that syncthing and homeassistant failed to start. (restart doesn’t help)

ps: could this be because rootfs and dietpi-userdata are on sda1? (ssd)

To fix Syncthing, please run:

chown -R dietpi:dietpi /mnt/dietpi_userdata/syncthing*
systemctl restart syncthing


For SMB, if it worked at the beginning, review your filter changes to check which one broke access? :wink:

For Homeassistant, I can do some test. However error messages or logs you encountered would be helpful.
EDIT: Same issue, please run:

chown -R homeassistant:homeassistant /mnt/dietpi_userdata/homeassistant
systemctl restart home-assistant

Location of userdata should not play a role unless the external drives file system supports UNIX permissions. But that is checked when transferring userdata and rootfs.

fix worked! Thnx ( i started from scratch, smb works too…)

Is it possible to overclock the Pi 4 to 2.147 Ghz running the latest version of DietPi?

My Pi 4 doesn’t even boot when I select the High ARM in dietpi-config so maybe I lost the silicon lottery as-is but I’m just curious if we can go higher.


Try to increase the overvoltage manually in /DietPi/config.txt (or config.txt from boot partition when plugging the failing SDcard into external system). Since it runs mostly stable with overvoltage 4, we set it to 5 already to be failsafe but probably there are some boards where even 6 is required.

Higher ARM clocks are possible like on Raspbian but out presets only contain values that run with usual cooling systems on acceptable temperatures.

I installed the 64-bit Dietpi version,
Image : DietPi Core Team (pre-image: Raspberry Pi OS (64-bit))

but I get ’ No supported WiFi hardware was found. ’

How do I enable the WLAN chip ?

I see you posted same question on GitHub.
Let’s stick to one platform pls. It doesn’t make sense to raise same question multiple times. :wink:

According DietPi statistics Rpi4 is the most used SBC now. going to mark this as solved.