The following packages have been kept back

When running sudo apt-get update && sudo apt-get upgrade I am getting the below message:

The following packages have been kept back:
linux-image-4.14-armhf-odroid-xu4

I am wondering if this is intended or if I should be doing something else?

When running uname -a I get the message below:

Linux DietPi 4.14.176+ #1 SMP PREEMPT Tue Apr 14 20:02:49 UTC 2020 armv7l GNU/Linux

Hi,

many thanks for your message. First I would recommend to perform a dietpi-backup. Just in caste thinks will go wrong. Once done, you could try following:

apt update
apt dist-upgrade

Thanks I will do that shortly

Looks like everything went fine, thanks for your help. Not sure what the differences was with that version though.

some documentation for your question. If you have time to to read thru, it might be interesting :slight_smile:

https://askubuntu.com/questions/194651/why-use-apt-get-upgrade-instead-of-apt-get-dist-upgrade