Teamviewer host on DietPi For RP3

The question might be a bit stupid…Anyone here has any luck to get teamviewer host to run on dietpi for rp3 with lxde? I cannot seem to get it work, I even tried upgrading jessie to scratch. However, without GUI, teamviewer could work on command line (i see command line when I remote in). Once xserver started, teamviewer will crash once I connect (and there is no GUI of teamviewer).

I tried the same installation file on Rasbian full version and it works well. Just trying my luck here if anyone knows how to get it to work >.<

PS: I do not mind switching to full raspbian from dietpi if that is possible. I put the RP3 in a remote site that I do not visit often, and no body there can switch the OS for me so I have to work on the existing OS installation which is dietpi for rp3 at the moment.

Any chance you got this to work I am having the same issue followed this instructions and got it installed but wont start up really need teamviewer on my dietpi raspberry please help

I gave up already. Tried installed quite alot of pkgs to make it similar to raspbian, but seems some packages are still missing, which I could not figure out. I will install raspbian next time i go back home.

Just an update, teamviewer 13 host is now working fine on the dietpi (I manually updated to stretch by modifying the apt source) as the pi is not easy for me to reach so i cannot update to V6.X.

Can you help with instructions to install on new system please