TeamViewer 15 on Raspberry Pi 4

I’m trying to use TeamViewer on the Raspberry Pi 4 with DietPi, but I’m unable finish the setup and connect.
Following the installation of the deb file, I’ve performed “apt install --fix-missing” and then “teamviewer setup” to login with my account.
Seems that the error lies on “check your internet connectivity” but internet is working properly (I’ve installed AdGuard Home as DNS resolver and it’s working properly). I’ve tried to manually set the DNS to but no luck. I’m able to use/register other devices with the same internet connection (tried both DSL & 4G).
Considering that this install is headless, I read here:
https://www. /forums/viewtopic.php?f=66&t=251567
That the RPi 4 headless configuration might cause issues. I’ve installed xrdp and set via dietpi-config the resolution to 1920x1080, but still no luck with TeamViewer. Using xrdp I can log in LXDE successfully.
Anyone able to use TeamViewer on RPi 4 with DietPi? Unfortunately, I can not use VNC or XRDP with forwarding because I need to access the RPi behind a 4G NATted connections.

Any hint?

TeamViewer 15 installed fine on DietPi 7.1 x64 VM and I was able to connect to the Mate desktop from my Windows PC. But it only always lasted only about a minute and the session will end. And shows the message

Guess TeamViewer think you should pay?