stretch for odroid

what about stretch for odroid

We use Meverics Debian minimal image as baseis:
This is so far just available with Jessie for all Odroids. Theoretically Stretch dist-upgrade is possible, but there are still several issues with software we offer, especially Kodi, but also others.

So far the plan is to wait, until Meveric offers Stretch officially, hopefully with also the issue we face fixed, before we go for it.


Is there any compelling reason to go to stretch, and on the upgrade topic, to 4.4/4.9 kernels for odroids like xu4?

I keep having the same desire to upgrade to latest OS/kernel/etc but then realise the effort isnt worth the hassle (usually after I waste a morning installing and eventually reverting back to what I had).

My experience with XU4 was that kernel 4.9 resulted in smoother 1080 video playback with Emby. I have also upgraded XU4 to Stretch using one of the standard Debian guides you find and it worked 99% but took a bit of effort. Only thing I could not get working was https with Medusa (SickRage fork) and self signed ssl cert. Reverted back to Jessie.

But interesting exercise, use a cloned SD card, nothing to lose but time.


Generally Stretch offers a lot of Debian package updates, first of all important for me was PHP7.0 (performance!), but also several others, database and system modules with enhanced security, performance and here and there tiny nice feature additions. Also the further integration of systemd and most packages use systemd services since Stretch, was an argument for me. It looks just way more consistent over all.

But yeah in the end, if it’s just about the e.g. web services one uses, the really noticeable differences might be still marginal.

Kernel versions are by the way independent from os version. Of course the default APT repositories usually offer a frozen major kernel version, but there are always ways to upgrade to next major version, if needed for e.g. some file transfer performance changes or special features, that some of our software titles also need. On RPi e.g. use rpi-update, in case with BRANCH=‘next’ rpi-update to upgrade to next major version, currently 4.14 :smiley:.

Hi johnvick,

I did the upgrade to stretch from dietpi v6 on a xu4.
Did you get meverics apt-repository working on stretch? I am getting this:

Reading package lists... Done
E: Method https has died unexpectedly!
E: Sub-process https received a segmentation fault.
E: Method /usr/lib/apt/methods/https did not start correctly
E: Failed to fetch
E: Some index files failed to download. They have been ignored, or old ones used instead.

The only repo I added is meveric-all-XU3. As with all of his repos this is reachable over https only.

kind regards

I don’t remember having errors like you had. As mentioned it was working 99% but one key feature didn’t as noted so I reverted to Jessie. I have since wiped the SD card I used for this I am afraid.


Just in case someone else runs into the same problem.
I had to install apt from stretch testing, that’s v1.6 beta :thinking: Now I only have a missing public key warning from meverics repo. Kernel update worked.


I have very same issue - thank you for information.

Regards Chris