start x doesnt work

i just installed dietpi on my raspberry pi 3b and when i type the startx command it says that command doesnt exist
i dont know what i did wrong.

every help is welcome

You need to install a desktop. Just open dietpi-software and select the one you like from search menu.

ok i think i did imma check it later i will say it if it worked

thanks for your fast respond. :slight_smile:

It can be easily checked like this

dietpi-software list | grep " =2 "

I chosen LXQt lightweight desktop

Did you selected it as desktop preference or vie search function and actually hit install as well? Does it show up on the command I posted above? Did you try to select it as autostart option? Usually this question should have been ask after installation completed

yes but somehow it said that there where no changes detected but after quiting the changes are still saved
and somehow i cant type the: | if i do this will apear: ~

am not good at reading english so if possible a few photos help

Pls share output of following command

dietpi-software list | grep " =2 "

An idea how to resolve the preference menu confusion:

so do i have to change dietpi.txt?

for the first step, pls can you simply share output of

dietpi-software list | grep " =2 "

yeah ik know but the code u wrote to me: dietpi-software list | grep " =2 " for some reason the | icon doesnt work on my keyboard and other icon keys are switched and some doesn’t exist

i have currently runner raspberian os on it as a backup for it until i fixed it

the | icon doesnt work on my keyboard and other icon keys are switched

In general have a look to dietpi-config to change keyboard layout. Or do you connect via SSH? If using SSH, simply copy/past the command

ok found it the writing did not go well thats why

thanks for your fast respond i hope i dont have to create hire a post again :wink:

does your issue has been fixed and could be marked as solved?

yes its solved