SSH NOT working after 158/159 update

Not logged on remotely for a while after I updated to 158 - can NOT login via SSH anymore ?? Tried updating to 159 but still does NOT work; ‘Bad Credentials’ or ‘Permission Denied’ . Running a RaspberryPi 3B / Stretch / Nginx DietPi setup. Please beware I’m fairly n00bish in some of these tech matters. :smiley:


Thanks for the report.

We’ve not changed anything specific in relation to SSH servers during patching.

Can you confirm the following:

  • User attempting to login (eg: pi)
  • Have you changed the system password in dietpi-config or other means?
  • PSU used (eg: official RPi 5v/2.5A
  • SD card used
  • SSH server installed (if you have not changed this in dietpi-software choice selection, it will be dropbear)

well as I’m running it as a blog/webserver (headless) I’ve not had to tinker much with it BUT I changed password IMMEDIATELY after a mild panic when I tried to SSH into it. Hooked it up to screen - everything else working OK , blog running fine and VNC works as well. I have it hardwired to the router BTW. OHH I’m running it off a Sandisk 32Gb USB stick but as said had NO issues so far. Used OpenSSH from DietPi software install initially - should I try to remove and reinstall ??

My SSH also failed. I posted the output of a login in another thread.