SSH Not Listening? Fresh Pi Zero W / Stretch and Jessie

I’m configuring my first pi to run piHole for my network and am not able to connect to the device once it associates with my wifi.

Tried both Stretch and Jessie after finding a few threads here indicating there were potentially some wifi driver issues in Stretch. The pi appears to connect to my wifi but does not accept ssh calls.

Using the automated setup flag, almost all setup defaults just to make things easy. All I do is change the hostname so I can validate the customs have run when I look at the device in my router’s device table. The router shows the little guy attached. I just can’t reach it either with any ssh client.

What can I do to keep prodding and/or obtain some feedback from the machine itself so I’m not just continuing to stab in the dark?

Raspbian is taking and offering ssh. Believe I may just need to drop an ssh file into the fat boot partition and will give that a go.

ssh file at the root got it

This is not required on DietPi.

As long as you set either
AUTO_SETUP_SSH_SERVER_INDEX=-1 (dropbear, default value) or
inside /boot/dietpi.txt (root of the images FAT partition) before first boot up, SSH should be available.

If the above was true and WiFi connects but SSH not, then perhaps boot scripts hang on some point. Do you have a chance to attach keyboard and HDMI to check local terminal outputs?
And does everything (1st run setup) work well, as long as you have Ethernet attached? When accessing locally via keyboad+HDMI, please try to disable Ethernet adapter actively via dietpi-config > Network Options: Adapters, when activating WiFi. If both are active and connected, then the lack of a route map currently would break internet access.

Indeed we had some automated WiFi settings applying and interface startup issues on DietPi v6.16, e.g. when special characters ($"’) were used in either SSID or key, and on some other special cases. v6.17 is live now, which should resolve them, but yeah on 1st boot of course it needs to work already to allow auto update to v6.17.

Thanks for responding MichaIng.

That’s how I originally approached it though for some reason it was failing. I do not have a mini-hdmi interface unfortunately otherwise I would really be interested in pursuing this further.

After I reported success, for some reason my ssh session died and I was never able to reconnect to that 0W with DietPi on it. For the time being, I’ve just snagged Raspbian Lite and have piHole running on there.