Ssh doesn't work after some time connected via wifi

Hi, I have installed dietpi on an old netbook to use it as nas connected to my external hard drive. The problem comes in that it connects correctly by wifi using dietpi-config, but a few hours later it seems that it disconnects and I cannot access it by ssh or by the web interfaces (radarr or deluge), I have to restart to make it work again. I have tried activating the wifi monitor service but it has not worked.

What I can do? Thank you

Hi,

many thanks for your message. If you like to activate the WiFi Monitor Service, do the following:

systemctl enable dietpi-wifi-monitor.service
systemctl start dietpi-wifi-monitor.service

status can be checked as follow

systemctl status dietpi-wifi-monitor.service

Thanks but I’ve already tried it and it doesn’t work for me

what does it mean, it dosn’t work? Is the service running but you still have disconnects?

It connects but after several hours, I can’t access it via ssh or the web interface and I have to reboot. The service is running and remains the same.

once WiFi connect dropped, do you still have access to the system via connected Keyboard / Screen to check what happen?

Yes, I can access because it is a laptop

Once connection dropped, you could do following trying trying to find out what happen:

  • check kernel messages using dmesg
  • check status of WiFi monitor service using systemctl status dietpi-wifi-monitor.service
  • check journal messages using journalctl to see what happen
  • check WiFi adapter using dietpi-config

Okay, I’m going to wait until it drops and I try to see what’s going on. I keep reporting, thank you

I am attaching an error message that looks like it is wifi related. What I can do? Maybe a backport to a higher version of the kernel?

according time stamp in your screen print, this happen 5 sec after boot. Not sure if this has a relation to your failing WiFi as this happen on a later stage (hour later)

That is true, I have tried doing the dietpi-config connection test and it seems that it is connected to the internet but I cannot access it in any way (web or ssh). The wifi monitor service is active and I cannot find any suspicious messages in dmesg or journalctl, at the time of disconnection, only these messages appear, attached screenshot.

Are you able to ping anything on the web like Google or any other website once connection seams to be dropped ?

Yes, it only fails when trying to connect via ssh or web interface

Are you able to ping DietPi devices from outside once connection failing?

Okay, this is weird but on some devices on my local network I can ping and on others I can’t. From a raspberry with dietpi I can ping, but from my windows computer I cannot ping. Attached screenshots, the ip in my local network is 192.168.1.110

EDIT: Sorry for the first one in Spanish but it says that all the packages have been lost.
ping windows.PNG
ping raspi.PNG

Indeed strange that connection is working for some devices. Can you use SSH from the PRi to the netbook?

How are all these devices connected? I mean the .101, the 110, and .130 .
Are they by cable or Wifi? Are they all in the same network? Is there wireless client isolation by any chance?
Is there a switch in your network? If yes is it managed?
Which router are you using?

I think I have solved the problem, my local network is made up of two routers (the main one and an access point), the devices connected to the main one can connect by ssh but those of the access point cannot. I have tried changing various settings of ap router and it worked by changing Network Key Rotation Interval field from 3600 to 0.

The 130 and 110 was connected to the router ap and the 101 to the main router, there the problem.

ok good. how it’s solved