Squeezelite error open audio device format

Hi all,

I have DietPi running on a RaspberryPi 3 and I’m having trouble getting Squeezelite to work. The Pi is connected to a Meridian Explorer DAC v1. Things work perfectly using it as a Roonbridge but I’d also like to use it as a Squeezelite player for my Logitec Media Server.

I’m running the latest version of LMS and I’ve tested Squeezelite running on a RPi2 running Volumio and that works fine so it doesn’t seem to be any inherent problem with Squeezelite and my version of LMS.

Basically what I’m doing is stopping Roonbridge and starting Squeezelite. It starts up fine and LMS immediately recognizes DietPi-Squeezelite as a player. However, when I try to play any music, nothing happens. I checked the Squeezelite log and here is what I’m seeing there…

[20:57:28.826281] alsa_open:425 unable to open audio device requested format: S16_LE

If I tail the log, that error recurs every 5 seconds.

I’m wondering about the format of S16_LE because when I check the output format with music playing through the Pi as a Roonbridge, the alsa output format is shown as S32_LE.

I’ve also tried uninstalling Roonbridge completely to make sure it wasn’t grabbing exclusive access to the DAC but I had the same problem. I’ve also uninstalled and reinstalled Squeezelite but no luck.

I’m not sure what else to look at. Any suggestions?

After a bit of research and debugging, I’ve found that the Squeezelite service file: /etc/systemd/system/squeezelite.service is hardcoding the ALSA parameters for the S16_LE format. I modified the ALSA parameters in the squeezelite.service file from 4096:1024:16:0 to 4096:1024::0 and now Squeezelite auto-detects the appropriate format for the DAC.

I’ve tested with a Dragonfly v1 which is the S24-3LE format and a Meridian Explorer which is S32_LE format and both worked fine with the new ALSA startup parameters.

Good job!

Thanks this helped me