Sonarr Mono is not running with --debug switch


The last few days in sonarr I get this error in logs Mono is not running with --debug switch

Sonarr is running but doesn’t perform automatically search for the missing episodes

I tried this command

/usr/bin/mono -O=-aot /opt/NzbDrone/NzbDrone.exe -nobrowser -data=/mnt/dietpi_userdata/sonarr

But I get the below

Cannot open assembly ‘/opt/NzbDrone/NzbDrone.exe’: No such file or directory.

Any advice how can I fix it?

Was there an issue of filling the troubleshooting template?

not sure if there is a misunderstanding. But NzbDrone was an old name/executable for Sonarr. Nowadays we start Sonarr using

/usr/bin/mono /usr/lib/sonarr/bin/Sonarr.exe -nobrowser -data=/mnt/dietpi_userdata/sonarr

Thank you for your reply

I tried the above and I get the below

[Warn] MonoDebugCheck: Mono is not running with --debug switch

I think you need to add --debug to get rid of this warning:

/usr/bin/mono --debug /usr/lib/sonarr/bin/Sonarr.exe -nobrowser -data=/mnt/dietpi_userdata/sonarr

this is a warning, northing more and you should be able to ignore them.