Sonarr and Radarr "Folder is not writable by user"

Hi all,

My setup is an N2+ with eMMC, one SSD and one HDD. I’ve moved the userdata to the SSD and want to use Sonarr and Radarr to download to the HDD where Plex’s library is located. I’ve created the folder hierarchy in the terminal but I’m getting this error when I point to them.

Example path is: /mnt/HDD/Plex/TV

I read in the details here that both Radarr and Sonarr are stuck to /mnt only so it should work regardless… I’ve also changed the permissions under File Management like the attached screenshot at each post. Is there something I’m missing here? Because if everything is locked to the user_data then that will also be a problem for Plex right? So how would having multiple external drives work?

Hi,

many thanks for your request. Pls can you share folder permissions of directory in question

la -la /mnt/HDD/Plex/TV

What file system format you are using on the external HDD?



root@DietPi:~# la -la /mnt/HDD/Plex/TV                           
total 8                                                          
drwxrwxrwx 2 root root 4096 Aug 25 21:35 .                       
drwxrwxrwx 4 root root 4096 Aug 25 17:54 ..

I’ve changed the permissions to 777 and it worked. What appears to not be working is when a file finishes downloading it doesn’t delete it from userdata/downloads (it does copy it to the location I want though)

It’s in EXT4

ok it seems /mnt/HDD/Plex/TV is owned by user root. Therefore it’s logic that Sonarr and Radarr are not able to write to this folder. It’s not elegant but you fixed it using 777 permission. :wink:

let’s have a look to /mnt/dietpi_userdata/downloads how this looks like

ls-la /mnt/dietpi_userdata/downloads

I’m not sure if it’s working properly still though, it seems to but by giving 777 permissions it should be enough right?

Because if you want Sonarr to download to Plex library it needs to be owned by Sonarr, but what about Plex?

root@DietPi:~# ls -la /mnt/dietpi_userdata/downloads             
total 8                                                          
drwxrwxr-x  2 dietpi dietpi 4096 Aug 25 23:16 .                  
drwxrwxrwx 11 dietpi dietpi 4096 Aug 25 19:41 ..

I guess it’s easier to discuss both of your issues together.

To allow all applications access to same folder, all application users would need to be member of same user groups. Usually Sonarr, Radarr and Plex should be part of group dietpi already. Let’s check it.

groups sonarr radarr plex

I just checked it and yes they are indeed. I just tried another download through Sonar and the file wasn’t moved from userdata/downloads to mnt/hdd/plex/tv so I’m guessing something’s definitely wrong :confused:

By the way, thanks for your patience.

why are you not going to download to /mnt/hdd/plex/tv directly?

Because I can only select one default path and it defaults to userdata/downloads. Since I’m using radarr and sonarr (two different locations) I don’t see how it’d be possible?

http://imgur.com/a/NbQwTTs

I think everything is working now. I believe the issue was either qbittorrent as I had set to remove on 0 seeding ratio or the permissions.

Either way, if you don’t mind I’ll take this opportunity to ask something really quickly. I uninstalled qbittorrent because it looked like it was using quite a lot of cpu to try transmission and it looks to be the same? Is this expected? With just a single torrent?

https://imgur.com/a/8CW7Mr9

it should not be a problem. It’s just 1 cpu core out of 6. And even this one is loaded at 50% only.