[Solved] VMWare img on ESXI 6.5

Could you update the VMware image so its compatible with ESXI 6.5 please? Currently on import when trying to edit it crashes and it won’t start.

Was there any progress on this? Anything I can do to help troubleshoot/bug test?
thank you.

Hi,

Is ESXI 6.5 not backwards compatible with VMware config and HW version 8 (ESXi 5.0)?

config.version = "8"
virtualHW.version = "8"

If not, we’d need to update to HW version 13, but that will break < ESXi 6.5, and possibly VMware player/workstation:

This virtual machine (hardware version 8) is compatible with ESXi 5.0, ESXi 5.1, ESXi 5.5, ESXi 6.0, and ESXi 6.5.

Strange. Claims its compatible. Is your host ESXI system stable with other VM’s?

My ESXI install has been robust with everything else Ive thrown at it - something like 18 VMs across Windows, FreeBSD and some other Linux verisons. I’ll dig into compatibility with ESXI 5 but given theres a workaround for this, I’d probably advise you stick where you are… I think… let me get back to you after Ive done some digging this weekend.

EDIT: The workaround was to import the dietpi install into Fusion 8.5, convert to a flat disk of 8GB and export that for import into ESXI 6.5 - that worked fine.

Hi guys,

I have been struggling for days with this over Xmas. DietPi will not start full stop on my ESXi (6.7), so I have tried clean Raspbian and Debian 9 OS install and then run the script from the native OS. Will not work, for some reason DNS errors and so updates Debian, have no DNS issues.

If somebody is willing to help me get this working I am happy to create a tutorial either write-up or video.

Thanks

big_g_uk
Thanks for your report.

Just to clarify:

  • You installed fresh Debian image successfully and it works well, allowing APT upgrades and other web access without DNS errors?
  • Then you ran DietPi-PREP to install DietPi on it?
  • While DietPi-PREP is running you face DNS resolve errors, e.g. during the APT steps done within the script?
  • Or did the DNS errors appear after the script has successfully finished and reboot done?

Thanks MichaIng,

It was my DNS server causing the issue. All resolved now, and Debian 9 VM ran prep script without issue.

Much appreciate you support.

Great it works now and thanks for the reply :slight_smile:.