[Solved] Upgrade MariaDB 10.1 on Arm (Raspi)

Hi there!

I’m trying to replace my Celeron Nextcloud server with a Raspberry Pi 3. Therefore I want to switch from Ubuntu 18.04 to DietPi.
Unfortunatly, I’m using MariaDB 10.3 on Ubuntu, DietPi is still on 10.1. As the Raspi is an ARM platform there are no official builds for ARM, but I need a newer version of MariaDB to import my NC databse backup because of this https://github.com/gogs/gogs/issues/4894.

What’s the easiest way to get MariaDB 10.3 to run on DietPi? Compiling from source and creating my own .deb package? Never done that before… Or does anybody know a repository for MariaDB 10.3 on ARM? Couldn’t find that …

Waiting for DietPi based on Debian Buster is no real option! :sunglasses:

Hmm, at least on DietPi installing MariaDB by default sets innodb_file_format=Barracuda, innodb_large_prefix=on and UTF8 table collation. From the issue you linked I could not 100% reliable get that this is sufficient, however perhaps worth to try? Also there is a post install solution provided by altering the table manually, though a bid hacky.
EDIT: If you want to try it out, tell me first. DietPi’s Nextcloud install allows automated backup migration, if you place the old install dir and database dump into certain folder structure.

Installing MariaDB 10.2/3 on Debian Stretch is definitely the harder work. Adding the Buster repo leads to a rats tail of installing many possibly incompatible dependencies, otherwise a custom build would be required.

I run my DietPi Buster on my RPi2 successfully, using https://github.com/Fourdee/DietPi/issues/1285 on top of Raspbian Lite :sunglasses:. However I can absolutely not recommend it. Debian Buster works flawlessly but Raspbian Buster regularly has critical APT repo issues that are veeery annoying and you have to take care to not destroy your system or have a bunch of packages removed due to dependency conflicts. See: https://github.com/Fourdee/DietPi/issues/1286#issuecomment-429478836

At least we could just fix a MariaDB 10.3 issue with latest DietPi version due to deprecated settings. Switch from 10.1 to 10.3 was just some days ago.

Thx for your help!

I just solved the problem with the help of https://help.nextcloud.com/t/solved-syntax-error-or-access-violation-1071-specified-key-was-too-long-max-key-length-is-767-bytes/34740.

The three commands

SET GLOBAL innodb_file_format=Barracuda;
SET GLOBAL innodb_file_per_table=on;
SET GLOBAL innodb_large_prefix=on;

solved the problem for me. Sometimes they seem not to work as the comments show.

Ah yeah. As said these are set automatically when installing Nextcloud via DietPi-Software: https://github.com/Fourdee/DietPi/blob/master/dietpi/dietpi-software#L8023-L8030